参考资料与延伸阅读¶
全书两种语言使用相同的参考编号。正文中的上标【数字】链接到对应来源;编号仅标识资料,不表示资料的优先级。章节末尾原有的阅读建议和来源限定保留在下方“各章阅读说明”中。仅列为延伸阅读的资料不被视为某一段论述的直接证据。
编号来源¶
【1】 BERT: Pre-training of Deep Bidirectional Transformers for Language Understanding
【2】 Language Models are Few-Shot Learners(GPT-3)
【3】 Language Models are Unsupervised Multitask Learners(GPT-2)
【4】 Emergent Abilities of Large Language Models
【5】 Are Emergent Abilities of Large Language Models a Mirage?
【6】 Scaling Laws for Neural Language Models
【7】 Training Compute-Optimal Large Language Models(Chinchilla)
【8】 The Llama 3 Herd of Models
【10】 Exploring the Limits of Transfer Learning with a Unified Text-to-Text Transformer(T5)
【11】 On Layer Normalization in the Transformer Architecture
【12】 Root Mean Square Layer Normalization
【13】 GLU Variants Improve Transformer
【14】 Query-Key Normalization for Transformers
【15】 Transformer Feed-Forward Layers Are Key-Value Memories
【16】 Fast Transformer Decoding: One Write-Head is All You Need(MQA)
【17】 GQA: Training Generalized Multi-Query Transformer Models from Multi-Head Checkpoints
【18】 Llama 2
【19】 DeepSeek-V2 论文与官方实现
【20】 FlashAttention
【21】 FlashAttention 官方仓库与版本要求(2026-07-06 README 快照)
【22】 Online normalizer calculation for softmax
【23】 Mistral 7B
【24】 Linformer
【25】 Rethinking Attention with Performers
【26】 Mamba: Linear-Time Sequence Modeling with Selective State Spaces
【27】 RoFormer: Enhanced Transformer with Rotary Position Embedding
【28】 ALiBi: Train Short, Test Long
【30】 YaRN: Efficient Context Window Extension of Large Language Models
【31】 Hugging Face Transformers:RoPE 参数与变体
【32】 BLOOM 模型卡
【33】 MosaicML:MPT-7B 发布说明与 ALiBi 配置
【34】 Lost in the Middle: How Language Models Use Long Contexts
【35】 Neural Machine Translation of Rare Words with Subword Units(BPE)
【36】 SentencePiece: A simple and language independent subword tokenizer
【37】 Subword Regularization: Improving NMT Models with Multiple Subword Candidates(Unigram)
【38】 Hugging Face: Tokenizers 教程
【39】 OpenAI tiktoken
【40】 Meta Llama 3 Tokenizer 官方实现
【41】 Google SentencePiece 官方实现与配置说明
【42】 Hugging Face Transformers:Tokenization algorithms
【43】 Hugging Face Transformers:Chat templates
【46】 The Llama 3 Herd of Models,§3、§4
【47】 Chinchilla:训练计算量近似
【48】 InstructGPT
【49】 LIMA
【50】 Deep Reinforcement Learning from Human Preferences
【51】 DPO:奖励重参数化与偏好损失
【53】 Qwen3 Technical Report,初版
【55】 LoRA
【56】 QLoRA
【57】 Transformers v4.46.3:Model training anatomy
【58】 PEFT:LoRA 配置与初始化
【59】 Parameter-Efficient Transfer Learning for NLP
【60】 PEFT v0.17.0:LoRA 配置、初始化与缩放
【61】 PEFT:Model merging 与 add_weighted_adapter
【62】 PEFT v0.17.0:加权 adapter 的实现与限制
【63】 vLLM:LoRA adapters
【64】 Constitutional AI
【65】 RLAIF vs. RLHF
【66】 Proximal Policy Optimization Algorithms
【67】 OpenAI Spinning Up:PPO-Clip 公式与约束边界
【68】 High-Dimensional Continuous Control Using Generalized Advantage Estimation
【69】 The Curious Case of Neural Text Degeneration
【70】 If Beam Search Is the Answer, What Was the Question?
【71】 Fast Inference from Transformers via Speculative Decoding
【72】 Self-Consistency Improves Chain of Thought Reasoning in Language Models
【73】 PagedAttention:包含 beam search 的缓存共享设计
【74】 Qwen3-30B-A3B 官方模型卡
【76】 Transformers:Generation Utilities,含 Temperature/TopK/TopP LogitsWarper
【77】 Transformers v4.56.2:贪心、采样与束搜索的配置条件
【78】 Anthropic 官方 Prompt Caching cookbook
【79】 Anthropic 官方 SDK:缓存 TTL 类型
【81】 KIVI 原论文
【82】 vLLM:Automatic Prefix Caching 设计
【83】 GPTQ: Accurate Post-Training Quantization for Generative Pre-trained Transformers
【84】 AWQ: Activation-aware Weight Quantization for LLM Compression and Acceleration
【85】 LLM.int8(): 8-bit Matrix Multiplication for Transformers at Scale
【86】 SmoothQuant: Accurate and Efficient Post-Training Quantization for Large Language Models
【87】 Optimal Brain Compression: A Framework for Accurate Post-Training Quantization and Pruning
【88】 llama.cpp / GGUF
【89】 AutoAWQ
【90】 GPTQ 作者实现:列顺序、act-order 与分组
【91】 AWQ 原论文:逐通道缩放与搜索
【92】 PyTorch AO:Quantization-Aware Training
【93】 FP8 Formats for Deep Learning,v1,第 2–3 节与表 1
【94】 OCP Microscaling Formats (MX) Specification v1.0
【95】 微软 MX 库:最大指数缩放与 scale 边界,固定版本
【96】 NVIDIA:Introducing NVFP4 for Efficient and Accurate Low-Precision Inference
【97】 NVIDIA Transformer Engine:FP8 入门与 MXFP8/NVFP4,固定版本 notebook
【98】 NVIDIA Transformer Engine:缩放配方、历史最大值与 margin,固定版本源码
【99】 gpt-oss-120b 与 gpt-oss-20b 模型卡,v1,第 2.1 节与表 1:MXFP4 MoE 权重与 checkpoint 大小
【100】 AMD ROCm 博客:CDNA3 与 CDNA4 上的 FP8 FNUZ 与 OCP 变体
【101】 ONNX:FP8 正规数/次正规数解码与特殊值编码
【102】 vLLM v0.10.2:E4M3FN 到 E4M3FNUZ 的规范化,固定版本实现
【103】 Calibrate Before Use: Improving Few-Shot Performance of Language Models(示例与顺序偏差)
【104】 Chain-of-Thought Prompting Elicits Reasoning in Large Language Models
【105】 Large Language Models are Zero-Shot Reasoners(Let's think step by step)
【106】 LLMLingua: Compressing Prompts for Accelerated Inference of Large Language Models
【107】 LongLLMLingua: Accelerating and Enhancing LLMs in Long Context Scenarios via Prompt Compression
【108】 The Power of Scale for Parameter-Efficient Prompt Tuning(Soft Prompt)
【109】 OpenAI: Reasoning best practices(含分隔符与 CoT 提示的适用边界)
【110】 OpenAI: Structured Outputs
【111】 Least-to-Most Prompting Enables Complex Reasoning in Large Language Models
【112】 Tree of Thoughts: Deliberate Problem Solving with Large Language Models
【113】 Towards Understanding Chain-of-Thought Prompting: An Empirical Study of What Matters
【114】 Measuring Faithfulness in Chain-of-Thought Reasoning
【115】 s1: Simple test-time scaling
【116】 Do NOT Think That Much for 2+3=? On the Overthinking of o1-Like LLMs
【117】 OpenAI: Reasoning models
【118】 Anthropic Python SDK: 手动 thinking 配置
【119】 Amazon Bedrock: Extended thinking
【120】 On Faithfulness and Factuality in Abstractive Summarization
【121】 Survey of Hallucination in Natural Language Generation
【123】 Language Models (Mostly) Know What They Know
【124】 TruthfulQA: Measuring How Models Mimic Human Falsehoods
【125】 Retrieval-Augmented Generation for Knowledge-Intensive NLP Tasks
【126】 SelfCheckGPT: Zero-Resource Black-Box Hallucination Detection for Generative Large Language Models
【127】 Chain-of-Verification Reduces Hallucination in Large Language Models
【128】 Towards Understanding Sycophancy in Language Models
【129】 Sparsely-Gated Mixture-of-Experts Layer
【130】 GShard
【131】 Switch Transformers
【132】 Mixtral of Experts
【133】 DeepSeek-V3 Technical Report
【134】 Auxiliary-Loss-Free Load Balancing
【135】 Expert Choice Routing
【136】 ST-MoE:Router z-loss
【137】 SGLang: Efficient Execution of Structured Language Model Programs(RadixAttention)
【138】 Orca: A Distributed Serving System for Transformer-Based Generative Models(Continuous Batching)
【139】 vLLM 文档
【140】 vLLM: Automatic Prefix Caching
【141】 SGLang 仓库
【142】 Text Generation Inference 仓库
【143】 TGI 官方文档(维护模式说明,2026-09-15 核对)
【144】 TensorRT-LLM 仓库
【145】 llama.cpp:HTTP Server 能力与参数
【146】 TensorRT-LLM:Quick Start
【147】 vLLM:Chunked Prefill 与配置调优
【148】 vLLM:Disaggregated Prefilling
【149】 TGI:组件与 HTTP/gRPC 边界
【150】 TensorRT-LLM:LLM API 与 PyTorch backend
【151】 Measuring Massive Multitask Language Understanding(MMLU)
【152】 MMLU-Pro: A More Robust and Challenging Multi-Task Language Understanding Benchmark
【153】 Evaluating Large Language Models Trained on Code(HumanEval / Pass@k)
【154】 SWE-bench: Can Language Models Resolve Real-World GitHub Issues?
【155】 OpenAI: Why SWE-bench Verified no longer measures frontier coding capabilities
【156】 Training Verifiers to Solve Math Word Problems(GSM8K)
【157】 Measuring Mathematical Problem Solving With the MATH Dataset
【158】 GPQA: A Graduate-Level Google-Proof Q&A Benchmark
【159】 Judging LLM-as-a-Judge with MT-Bench and Chatbot Arena
【160】 Holistic Evaluation of Language Models(HELM)
【161】 LiveBench: A Challenging, Contamination-Limited LLM Benchmark
【162】 tau-bench: A Benchmark for Tool-Agent-User Interaction in Real-World Domains
【163】 HumanEval 官方 Pass@k 实现
【164】 SWE-bench 官方文档(Verified 子集)
【165】 Humanity's Last Exam
【166】 DeepSeek-V3 Technical Report
【167】 Qwen3 Technical Report
【168】 RouteLLM: Learning to Route LLMs with Preference Data
【169】 FrugalGPT: How to Use Large Language Models While Reducing Cost and Improving Performance
【170】 OpenAI: Data controls in the OpenAI platform
【171】 CLIP: Learning Transferable Visual Models From Natural Language Supervision
【172】 Flamingo: a Visual Language Model for Few-Shot Learning
【173】 LLaVA: Visual Instruction Tuning
【174】 Whisper: Robust Speech Recognition via Large-Scale Weak Supervision
【175】 Video-LLaMA: An Instruction-tuned Audio-Visual Language Model
【176】 NIST AI Risk Management Framework
【178】 Qwen2-VL: Enhancing Vision-Language Model's Perception of the World at Any Resolution
【179】 Hugging Face Evaluate:WER 指标定义与实现说明
【180】 Sigmoid Loss for Language Image Pre-Training (SigLIP)
【181】 ImageBind: One Embedding Space To Bind Them All
【182】 Perceiver IO: A General Architecture for Structured Inputs & Outputs
【183】 Qwen-VL:位置感知视觉语言适配器
【184】 Chameleon: Mixed-Modal Early-Fusion Foundation Models
【185】 Neural Discrete Representation Learning (VQ-VAE)
【186】 Taming Transformers for High-Resolution Image Synthesis (VQGAN)
【187】 OpenAI GPT-4o System Card
【188】 GPT-4o System Card(原始报告)
【189】 Grounding DINO: Marrying DINO with Grounded Pre-Training for Open-Set Object Detection
【190】 Grounded Language-Image Pre-training (GLIP)
【191】 Simple Open-Vocabulary Object Detection with Vision Transformers (OWL-ViT)
【192】 PaliGemma: A versatile 3B VLM for transfer
【193】 Molmo and PixMo: Open Weights and Open Data for State-of-the-Art Multimodal Models
【194】 Visual Genome: Connecting Language and Vision Using Crowdsourced Dense Image Annotations
【195】 Generation and Comprehension of Unambiguous Object Descriptions(RefCOCOg)
【196】 ReferItGame: Referring to Objects in Photographs of Natural Scenes
【197】 REFER:数据集来源与划分说明
【198】 LayoutLM: Pre-training of Text and Layout for Document Image Understanding
【199】 LayoutLMv3: Pre-training for Document AI with Unified Text and Image Masking
【200】 OCR-free Document Understanding Transformer (Donut)
【201】 PubTables-1M: Towards Comprehensive Table Extraction From Unstructured Documents
【202】 GriTS: Grid Table Similarity
【203】 Image-based table recognition: data, model, and evaluation (PubTabNet / TEDS)
【204】 ChartQA: A Benchmark for Question Answering about Charts
【205】 DocVQA: A Dataset for VQA on Document Images
【206】 Azure AI Document Intelligence 官方文档
【207】 Azure Document Intelligence:准确率与置信度
【208】 Google Cloud Document AI 官方文档
【209】 Amazon Textract 官方文档
【210】 Amazon Textract:AnalyzeDocument 与 FeatureTypes
【211】 Anthropic: Developing a computer use model
【212】 Anthropic:升级版 Claude 3.5 Sonnet 与 Computer Use 公开测试
【213】 Anthropic Computer Use 官方文档
【214】 OpenAI: Computer-Using Agent
【215】 OpenAI Operator
【216】 OpenAI:Computer Use 工具与执行环境
【217】 UI-TARS: Pioneering Automated GUI Interaction with Native Agents
【218】 OSWorld: Benchmarking Multimodal Agents for Open-Ended Tasks in Real Computer Environments
【219】 WebArena: A Realistic Web Environment for Building Autonomous Agents
【220】 Connectionist Temporal Classification(原论文)
【221】 Sequence Transduction with Recurrent Neural Networks (RNN-T)
【222】 Natural TTS Synthesis by Conditioning WaveNet on Mel Spectrogram Predictions (Tacotron 2)
【223】 Neural Codec Language Models are Zero-Shot Text to Speech Synthesizers (VALL-E)
【224】 SoundStream: An End-to-End Neural Audio Codec
【225】 High Fidelity Neural Audio Compression (EnCodec)
【226】 AudioLM: a Language Modeling Approach to Audio Generation
【227】 Qwen-Audio: Advancing Universal Audio Understanding via Unified Large-Scale Audio-Language Models
【228】 SALMONN: Towards Generic Hearing Abilities for Large Language Models
【229】 Moshi: a speech-text foundation model for real-time dialogue
【230】 Generative Spoken Dialogue Language Modeling (dGSLM)
【231】 OpenAI Realtime API 官方文档
【232】 OpenAI Realtime:会话状态与打断处理
【233】 Kyutai Moshi 项目主页
【234】 Denoising Diffusion Probabilistic Models (DDPM)
【235】 Denoising Diffusion Implicit Models (DDIM)
【236】 Score-Based Generative Modeling through Stochastic Differential Equations
【237】 High-Resolution Image Synthesis with Latent Diffusion Models (Stable Diffusion)
【238】 Classifier-Free Diffusion Guidance
【239】 Flow Matching for Generative Modeling
【240】 Flow Straight and Fast: Learning to Generate and Transfer Data with Rectified Flow
【241】 Scaling Rectified Flow Transformers for High-Resolution Image Synthesis (Stable Diffusion 3)
【242】 Photorealistic Text-to-Image Diffusion Models with Deep Language Understanding (Imagen)
【243】 OpenAI DALL·E 3: Improving Image Generation with Better Captions
【244】 GANs Trained by a Two Time-Scale Update Rule Converge to a Local Nash Equilibrium (FID)
【245】 CLIPScore: A Reference-free Evaluation Metric for Image Captioning
【246】 Video Diffusion Models
【247】 Imagen Video: High Definition Video Generation with Diffusion Models
【248】 OpenAI: Video generation models as world simulators (Sora 技术报告)
【249】 Stable Video Diffusion: Scaling Latent Video Diffusion Models to Large Datasets
【250】 Towards Accurate Generative Models of Video: A New Metric & Challenges (FVD)
【251】 VBench: Comprehensive Benchmark Suite for Video Generative Models
【252】 LAION-5B: An Open Large-Scale Dataset for Training Next Generation Image-Text Models
【253】 OBELICS: An Open Web-Scale Filtered Dataset of Interleaved Image-Text Documents
【254】 Aligning Large Multimodal Models with Factually Augmented RLHF (LLaVA-RLHF)
【255】 MMMU: A Massive Multi-discipline Multimodal Understanding and Reasoning Benchmark
【256】 MathVista: Evaluating Mathematical Reasoning of Foundation Models in Visual Contexts
【257】 Multimodal Neurons in Artificial Neural Networks (Typographic Attack)
【258】 Visual Adversarial Examples Jailbreak Aligned Large Language Models
【259】 C2PA 2.1 技术规范
【260】 Google DeepMind: SynthID
【261】 DistServe: Disaggregating Prefill and Decoding for Goodput-optimized Large Language Model Serving
【262】 OpenAI: Function Calling 指南(2026-09-08 核查)
【263】 OpenAI: Responses API 迁移指南(本节字段与示例于 2026-09-16 对照此页及 Function Calling 指南核查)
【264】 OpenAI: 2023 年 Function Calling 发布
【265】 Anthropic: Tool Use with Claude
【266】 Anthropic: Writing Effective Tools for Agents
【267】 Toolformer: Language Models Can Teach Themselves to Use Tools
【268】 ReAct: Synergizing Reasoning and Acting in Language Models
【269】 JSON Schema 规范
【270】 ToolLLM: Facilitating Large Language Models to Master 16000+ Real-world APIs
【271】 ToolRL: Reward is All Tool Learning Needs
【272】 ReTool: Reinforcement Learning for Strategic Tool Use in LLMs
【273】 Berkeley Function Calling Leaderboard
【274】 API-Bank: A Comprehensive Benchmark for Tool-Augmented LLMs
【275】 Anthropic: Building Effective Agents
【276】 MCP 版本状态
【277】 MCP 2026-07-28 变更记录
【278】 Model Context Protocol 官方文档
【279】 MCP 规范 2026-07-28
【280】 MCP 版本兼容说明
【281】 MCP 架构说明
【282】 Anthropic: Introducing the Model Context Protocol
【283】 JSON-RPC 2.0 规范
【284】 github/github-mcp-server
【285】 MCP Server 能力:Tools
【286】 MCP Multi Round-Trip Requests
【287】 MCP 弃用特性
【288】 MCP 传输层规范
【289】 订阅规范
【290】 MCP 服务端开发快速上手
【291】 MCP Servers 官方示例仓库
【292】 已归档 MCP 示例
【293】 MCP Roots:弃用状态与非安全边界
【294】 OpenAI: Function Calling 指南
【295】 OpenAI: o1-preview 模型页
【296】 OpenAI: o1 模型与快照
【297】 OpenAI Cookbook:o1-preview 初期结构化输出限制
【298】 Anthropic:Claude 4 交错工具使用发布说明
【299】 Anthropic Cookbook:早期 Claude 3.7 thinking 块保留示例
【300】 Anthropic: Extended Thinking
【301】 DeepSeek-R1: Incentivizing Reasoning Capability in LLMs via Reinforcement Learning
【302】 Anthropic: Introducing Agent Skills
【303】 Anthropic: Equipping Agents for the Real World with Agent Skills
【304】 Agent Skills 规范
【305】 Agent Skills 本次核查的固定提交
【306】 Claude Docs: Agent Skills
【307】 Anthropic: Effective Context Engineering for AI Agents
【308】 官方客户端列表
【309】 A2A v1.0.1 发布记录
【310】 A2A 协议官网
【311】 A2A v1.0.1 发布规范
【312】 A2A v1.0.1 规范数据定义
【313】 Google: Announcing the Agent2Agent Protocol
【314】 Linux Foundation: A2A Project
【315】 MCP 2026-07-28 Streamable HTTP
【316】 MCP 2026-07-28 stdio
【317】 MCP 规范 2025-03-26(Streamable HTTP 引入版本)
【318】 MDN: Server-Sent Events
【319】 MDN: The WebSocket API
【320】 MDN: WebRTC API
【321】 RFC 6455: The WebSocket Protocol
【322】 RFC 8445: Interactive Connectivity Establishment (ICE)
【323】 WebRTC 官方站点
【324】 WHATWG HTML:Server-sent events
【325】 RFC 8835:WebRTC 传输
【326】 RFC 8834:WebRTC 媒体与丢包恢复
【327】 RFC 8831:WebRTC Data Channels
【328】 RFC 8441:WebSocket over HTTP/2
【329】 RFC 9220:WebSocket over HTTP/3
【330】 OpenAI: WebRTC 接入(Realtime API 部分)
【331】 Squid v5 支持受配置控制的 Upgrade
【332】 LiteLLM 文档
【333】 LiteLLM GitHub
【334】 Bifrost 官方仓库(Go 实现)
【335】 LiteLLM 重试与故障转移
【336】 RFC 9111:HTTP 缓存
【337】 Portkey AI Gateway
【338】 Kong AI Gateway
【339】 Envoy AI Gateway
【340】 Langfuse: LLM 可观测性
【341】 OWASP Top 10 for LLM Applications
【342】 MCP 2026-07-28 Authorization
【343】 MCP 2026-07-28 Security Best Practices
【344】 RFC 9728: OAuth 2.0 Protected Resource Metadata
【345】 RFC 8252: 原生应用 OAuth 与 loopback 回调
【346】 RFC 9700: OAuth 2.0 Security Best Current Practice
【347】 RFC 7636: PKCE
【348】 RFC 8707: Resource Indicators for OAuth 2.0
【349】 Dense Passage Retrieval for Open-Domain Question Answering
【350】 Retrieval-Augmented Generation for Large Language Models: A Survey
【351】 Searching for Best Practices in Retrieval-Augmented Generation
【352】 Anthropic: Introducing Contextual Retrieval
【353】 Chroma Research: Context Rot — How Increasing Input Tokens Impacts LLM Performance
【354】 Can Long-Context Language Models Subsume Retrieval, RAG, SQL, and More?
【355】 Long-Context LLMs Meet RAG: Overcoming Challenges for Long Inputs in RAG
【356】 LongRAG: Enhancing Retrieval-Augmented Generation with Long-context LLMs
【357】 RAFT: Adapting Language Model to Domain Specific RAG
【358】 ColPali: Efficient Document Retrieval with Vision Language Models
【359】 Qdrant:Payload 更新与索引
【360】 Advanced ingestion process powered by LLM parsing for RAG system
【361】 Dense X Retrieval: What Retrieval Granularity Should We Use?
【362】 Qwen3-Embedding-0.6B 模型卡
【363】 Late Chunking: Contextual Chunk Embeddings Using Long-Context Embedding Models
【364】 Jina AI:Late Chunking 的编码后池化与边界说明
【365】 RAPTOR: Recursive Abstractive Processing for Tree-Organized Retrieval
【366】 LangChain 的 ParentDocumentRetriever
【367】 Efficient Estimation of Word Representations in Vector Space
【368】 Stanford GloVe:全局共现统计与加权最小二乘目标
【369】 Sentence-BERT: Sentence Embeddings using Siamese BERT-Networks
【370】 SimCSE: Simple Contrastive Learning of Sentence Embeddings
【371】 ColBERTv2: Effective and Efficient Retrieval via Lightweight Late Interaction
【372】 MTEB: Massive Text Embedding Benchmark
【373】 MMTEB: Massive Multilingual Text Embedding Benchmark
【374】 Matryoshka Representation Learning
【375】 OpenAI:New embedding models and API updates(2024-01-25)
【376】 OpenAI:Embedding API 与 dimensions 参数
【379】 pgvector 官方 README:过滤、迭代扫描、VACUUM 与扩展
【380】 FreshDiskANN: A Fast and Accurate Graph-Based ANN Index for Streaming Similarity Search
【381】 ACORN: Performant and Predicate-Agnostic Search Over Vector Embeddings and Structured Data
【382】 Billion-scale similarity search with GPUs
【383】 hnswlib v0.8.0:内部 ID、底层邻接容量与载荷布局
【384】 Self-RAG: Learning to Retrieve, Generate, and Critique through Self-Reflection
【386】 Lucene 9.12 BM25Similarity:词频饱和、长度归一化与 IDF 实现
【387】 SPLADE: Sparse Lexical and Expansion Model for First Stage Ranking
【388】 Elastic:ELSER 官方文档
【389】 Precise Zero-Shot Dense Retrieval without Relevance Labels
【390】 Take a Step Back: Evoking Reasoning via Abstraction in Large Language Models
【391】 Query Rewriting for Retrieval-Augmented Large Language Models
【392】 Reciprocal Rank Fusion outperforms Condorcet and individual Rank Learning Methods (SIGIR 2009)
【393】 Evaluation of Retrieval-Augmented Generation: A Survey
【394】 Corrective Retrieval Augmented Generation
【395】 Agentic Retrieval-Augmented Generation: A Survey on Agentic RAG
【396】 Active Retrieval Augmented Generation
【397】 From Local to Global: A Graph RAG Approach to Query-Focused Summarization
【398】 Microsoft GraphRAG 官方文档
【399】 Microsoft GraphRAG:索引方法
【400】 Microsoft GraphRAG:CLI(含更新方法)
【401】 Microsoft GraphRAG:查询模式
【402】 Microsoft GraphRAG:Local Search
【403】 LightRAG: Simple and Fast Retrieval-Augmented Generation
【404】 HippoRAG: Neurobiologically Inspired Long-Term Memory for Large Language Models
【405】 PathRAG: Pruning Graph-based Retrieval Augmented Generation with Relational Paths
【407】 Making Retrieval-Augmented Language Models Robust to Irrelevant Context
【408】 RAGAS: Automated Evaluation of Retrieval Augmented Generation
【409】 ALCE:Enabling Large Language Models to Generate Text with Citations
【410】 Ragas:Context Recall
【411】 Ragas:Context Precision
【412】 Ragas:Faithfulness
【413】 Ragas:Answer / Response Relevancy
【414】 CRAG - Comprehensive RAG Benchmark
【415】 TREC RAG Track
【416】 Fact, Fetch, and Reason: A Unified Evaluation of Retrieval-Augmented Generation
【417】 PoisonedRAG: Knowledge Corruption Attacks to Retrieval-Augmented Generation of Large Language Models
【419】 RAG-Anything: All-in-One RAG Framework
【420】 第五章:代码作为交互接口与生成 SQL 查询
【421】 README
【422】 agent.py
【423】 demo.py
【424】 聚合函数
【425】 URI 只读模式
【426】 授权回调
【427】 不可信 SQL 的安全措施
【428】 应用函数安全
【429】 执行计划
【430】 类型亲和性
【431】 STRICT 表及版本要求
【432】 《SchemaGraphSQL:使用寻路图算法高效完成大规模数据库 Text-to-SQL Schema Linking》
【433】 《重新思考 Schema Linking:面向 Text-to-SQL 的上下文感知双向检索方法》
【434】 agent.py
【435】 demo.py
【436】 demo.py 的比较流程
【437】 OpenAI Agents SDK: Agents
【438】 LangChain: Short-term memory
【439】 MCP joins the Agentic AI Foundation
【440】 A2A Protocol: Core Concepts
【441】 MCP Governance and Stewardship
【442】 Microsoft Agent Framework Overview
【443】 AutoGen Maintenance Mode
【444】 LangChain: Context Engineering for Agents
【445】 Drew Breunig: How Contexts Fail and How to Fix Them
【446】 Anthropic: Code execution with MCP
【447】 Cloudflare: Code Mode — the better way to use MCP
【448】 RAG-MCP: Mitigating Prompt Bloat in LLM Tool Selection via Retrieval-Augmented Generation
【449】 AGENTS.md
【450】 OpenAI Codex: Custom instructions with AGENTS.md
【451】 Reflexion: Language Agents with Verbal Reinforcement Learning
【452】 Reflexion 原文实验设置与表 1–2
【453】 ReWOO: Decoupling Reasoning from Observations for Efficient Augmented Language Models
【454】 An LLM Compiler for Parallel Function Calling
【455】 LangChain: Planning Agents
【456】 v2, §4.1 and Table 2
【457】 Graph of Thoughts: Solving Elaborate Problems with Large Language Models
【458】 PAL: Program-aided Language Models
【459】 Self-Refine: Iterative Refinement with Self-Feedback
【460】 Plan-and-Solve Prompting
【461】 Program of Thoughts Prompting
【463】 Let's Verify Step by Step
【464】 Scaling LLM Test-Time Compute Optimally can be More Effective than Scaling Model Parameters
【465】 Python 3.13: decimal — 精度、舍入与十进制计算
【466】 AWS Builders' Library: Making retries safe with idempotent APIs
【467】 SHOP 系列规划器:作者项目页与实现
【468】 Martin Kleppmann: How to do distributed locking(租约过期后的迟到写入与 fencing)
【469】 CoALA: Cognitive Architectures for Language Agents
【470】 MemGPT: Towards LLMs as Operating Systems
【471】 Generative Agents: Interactive Simulacra of Human Behavior
【472】 LangGraph: Memory overview
【473】 文档快照 1fa2214
【474】 OpenAI: Safety in building agents
【475】 LongMemEval 论文
【476】 官方说明快照 9e0b455
【477】 LoCoMo 论文
【478】 ACL 2024 发布说明快照 9228632
【479】 LongMemEval-V2 官方说明快照 2cc8c54
【480】 LongMemEval
【481】 LoCoMo
【482】 LongMemEval-V2
【483】 LangGraph: Persistence
【484】 文档快照 3edafc8
【485】 LangGraph: Checkpointers
【486】 AWS Prescriptive Guidance:Transactional outbox pattern
【487】 etcd v3.5:事务比较与 revision
【488】 Anthropic: How we built our multi-agent research system
【489】 Cognition: Don't Build Multi-Agents
【490】 Why Do Multi-Agent LLM Systems Fail? (MAST)
【491】 Raft:作者维护的算法与论文入口
【492】 AutoGen: Enabling Next-Gen LLM Applications via Multi-Agent Conversation
【493】 CAMEL: Communicative Agents for Mind Exploration of Large Language Model Society
【494】 Anthropic Prompt Caching
【495】 OpenAI Compaction
【496】 LangGraph Memory
【497】 LLMs Can't Plan, But Can Help Planning in LLM-Modulo Frameworks
【498】 Do As I Can, Not As I Say: Grounding Language in Robotic Affordances
【499】 OR-Tools: CP-SAT Solver
【500】 Reflexion: Language Agents with Verbal Reinforcement Learning(v4)
【501】 Language Agent Tree Search Unifies Reasoning, Acting, and Planning(v3)
【502】 Improving Factuality and Reasoning in Language Models through Multiagent Debate
【503】 Large Language Models Cannot Self-Correct Reasoning Yet
【504】 Training Language Models to Self-Correct via Reinforcement Learning(SCoRe,v1)
【505】 SCoRe
【506】 LangGraph Graph API
【507】 LangGraph:并行状态更新错误
【508】 OpenAI Agents SDK
【509】 OpenAI Swarm:迁移至 Agents SDK 的官方说明
【510】 OpenAI Agents SDK: Handoffs
【511】 Amazon SQS:至少一次投递
【512】 etcd v3.6:API 一致性与租约保证
【513】 etcd v3.6:Lock 与事务保护
【514】 LangGraph: add_messages Implementation
【515】 Diego Ongaro's Thesis: Replicated State Machines and Failure Assumptions
【516】 SWE-Lancer: Can Frontier LLMs Earn $1 Million from Real-World Freelance Software Engineering?
【517】 Terminal-Bench:官方任务与版本入口
【518】 GAIA: a benchmark for General AI Assistants
【519】 tau^2-Bench: Evaluating Conversational Agents in a Dual-Control Environment
【520】 BrowseComp: A Simple Yet Challenging Benchmark for Browsing Agents
【521】 AgentBench: Evaluating LLMs as Agents
【522】 MLE-bench: Evaluating Machine Learning Agents on Machine Learning Engineering
【523】 AgentDojo: A Dynamic Environment to Evaluate Prompt Injection Attacks and Defenses for LLM Agents
【524】 OpenTelemetry: Generative AI Semantic Conventions
【525】 OpenTelemetry: GenAI 约定状态说明(Development,固定提交 0c87594)
【526】 Anthropic: Demystifying evals for AI agents
【527】 SWE-bench: Evaluation harness
【528】 OpenAI: BrowseComp reference implementation
【529】 官方评估器
【530】 Simon Willison: The lethal trifecta for AI agents
【531】 Simon Willison: The Dual LLM pattern for building AI assistants that can resist prompt injection
【532】 Design Patterns for Securing LLM Agents against Prompt Injections(v1)
【533】 Defeating Prompt Injections by Design(CaMeL,v2)
【534】 The Task Shield: Enforcing Task Alignment to Defend Against Indirect Prompt Injection in LLM Agents
【537】 Docker Engine:Linux 容器的 seccomp 配置与边界
【538】 SWE-agent: Agent-Computer Interfaces Enable Automated Software Engineering
【539】 METR: Measuring AI Ability to Complete Long Software Tasks
【540】 Simon Willison: Designing agentic loops
【541】 Claude Agent SDK: Overview
【542】 GitHub Docs: Configure the development environment for Copilot cloud agent
【543】 Graph API
【544】 Functional API
【545】 Claude Agent SDK: How the agent loop works
【546】 OpenAI Agents SDK: Running agents
【547】 LangGraph: Subgraphs
【548】 Claude Agent SDK: Modifying system prompts
【549】 OpenAI Agents SDK: Guardrails
【550】 Claude Agent SDK: Configure permissions
【551】 gVisor 文档
【552】 GitHub Docs: Customizing or disabling the firewall
【553】 LangGraph: Interrupts
【554】 LangGraph: Fault tolerance
【555】 Temporal: Retry Policies
【556】 Stripe: Idempotent requests
【557】 OpenTelemetry: Traces
【558】 OpenAI Codex repository
【559】 第五章相关段落
【560】 edit_tool.py
【561】 Language Server Protocol 3.17
【562】 Python ast.parse 文档
【563】 失败归因、精确复制排查与轨迹前缀回归
【564】 多轮信用分配、奖励与在轨蒸馏
【565】 从问题案例到后训练
【566】 过早结束的 DPO 修复 README
【567】 LangChain 官方文档
【568】 LangGraph 官方文档
【569】 LlamaIndex 官方文档
【570】 CrewAI 官方文档
【571】 RunnableSequence:LCEL 组合、批处理与流式语义
【572】 Runnable API
【573】 langchain-core Runnables API 参考
【574】 LangChain v1 迁移指南
【575】 LangChain: Agents 概念文档
【576】 LangChain: Messages 概念文档
【577】 LangChain: Tools 概念文档
【578】 LangChain: Middleware 概念文档
【579】 LangChain: Structured Output
【580】 LangChain: Long-term Memory
【581】 LangChain: Streaming
【582】 LangChain Human-in-the-loop:审批与恢复
【583】 LangGraph Graph API:recursion limit
【584】 langchain-core Tools API 参考
【585】 Pydantic 官方文档
【586】 LangGraph Store 文档
【587】 LangChain: Retrieval 概念文档
【588】 LlamaIndex: Building an Agent
【589】 LlamaIndex: Workflows
【590】 LangChain4j 官方文档
【591】 LangChain4j GitHub 仓库
【592】 LangChain4j: AI Services 教程
【593】 LangChain4j: Tools 教程
【594】 LangChain4j: Chat Memory 教程
【595】 LangChain4j: RAG 教程
【596】 LangChain4j: Guardrails 与执行顺序
【597】 LangChain4j: AI Service Observability
【598】 Quarkus LangChain4j
【599】 Spring AI 官方文档
【600】 LangSmith 官方文档
【601】 LangGraph Python 包依赖声明
【602】 LangGraph: Time Travel
【603】 LangChain: Event streaming
【604】 LangChain v1 发布说明
【605】 LangChain v0.3 官方发布说明(Pydantic 2 迁移)
【606】 LangChain 官方博客
【607】 Pydantic 迁移指南
【608】 LangGraph Graph API:graph migrations
【609】 LangChain 官方博客:Open Deep Research
【610】 open_deep_research 官方仓库
【611】 Deep Agents 概览
【612】 Deep Agents Backends
【613】 Deep Agents Sandboxes
【614】 Deep Agents 同步子 Agent
【615】 Deep Agents 异步子 Agent
【616】 deepagents 官方仓库
【617】 LangSmith Evaluation 文档
【618】 LangSmith 管理 Dataset
【619】 LangSmith Online evaluation
【620】 LangSmith 用户反馈
【621】 LangSmith 发送前隐藏与转换敏感数据
【622】 LangSmith 实验重复次数、并发与缓存
【623】 LlamaIndex 官方文档
【624】 LlamaIndex: Loading Data (Ingestion Pipeline)
【625】 LlamaIndex: Indexing 概念
【626】 LlamaIndex: 各索引的默认与可选检索方式
【627】 LlamaIndex: Property Graph Index
【628】 LlamaIndex: Storage 概念
【629】 from_params() 不会自动发现应用已有的连接
【630】 LlamaIndex: Query Engine 概念
【631】 LlamaIndex: Routers 与 selector
【632】 LlamaIndex: Workflows
【633】 LlamaIndex: Workflows 共享状态
【634】 LlamaIndex: Durable Workflows
【635】 LlamaIndex: WorkflowServer 部署
【636】 LlamaIndex: BaseSynthesizer 的 query / nodes 接口
【637】 DSPy 官方文档
【638】 DSPy: Class-based signatures
【639】 DSPy: Changing modules
【641】 DSPy: 选择优化器
【642】 DSPy: MIPROv2 API 与三阶段机制
【643】 DSPy: GEPA API 与反馈契约
【644】 DSPy: GEPA 优化教程
【645】 GEPA 论文:Agrawal et al., "GEPA: Reflective Prompt Evolution Can Outperform Reinforcement Learning"
【646】 LangSmith 官方文档
【647】 Semantic Kernel 官方文档:Introduction
【648】 Semantic Kernel: Kernel 概念
【649】 Semantic Kernel: Plugins 概念
【650】 Semantic Kernel: Planning 概念
【651】 Semantic Kernel: Filters 概念
【652】 Semantic Kernel 官方仓库与后继框架说明(固定提交)
【653】 Semantic Kernel: Process Framework
【654】 Semantic Kernel: Agent Framework 概述
【655】 Semantic Kernel: Agent Orchestration
【656】 Semantic Kernel: Group Chat 完整运行时示例
【657】 SK → MAF 迁移指南
【658】 微软:Semantic Kernel 与 MAF 支持过渡公告
【659】 AutoGen 官方文档
【660】 AutoGen: Core 用户指南
【661】 AutoGen: AgentChat 用户指南
【662】 AutoGen 官方仓库:Maintenance Mode(固定提交)
【663】 AutoGen → MAF 迁移指南
【664】 AutoGen: 保存与加载 Agent/Team 状态
【665】 CrewAI: Flows 概念
【666】 CrewAI: Crews 概念
【667】 CrewAI: Processes 的顺序与层级执行
【668】 PydanticAI 官方文档
【669】 PydanticAI: Agents 核心概念
【670】 PydanticAI: Function Tools
【671】 PydanticAI: Dependencies 依赖注入
【672】 PydanticAI: 输出模式与校验
【673】 PydanticAI: Durable Execution
【674】 OpenTelemetry Generative AI 语义约定及状态
【675】 Martin Fowler: StranglerFigApplication
【676】 Martin Fowler: CanaryRelease
【677】 Alistair Cockburn: Hexagonal Architecture
【678】 Google Cloud: MLOps: Continuous delivery and automation pipelines in machine learning
【679】 a16z: What Is LLMOps?
【680】 Chip Huyen: Building LLM applications for production
【681】 OpenAI: Best practices for production deployments
【682】 Google SRE Book: Chapter 1 - Introduction
【683】 Uber Engineering: Michelangelo Machine Learning Platform
【684】 Martin Fowler: Continuous Delivery for Machine Learning
【685】 LiteLLM: Routing
【686】 Amazon Bedrock: Model routing (intelligent prompt routing)
【687】 Netflix Tech Blog: Fault Tolerance in a High Volume, Distributed System
【688】 Google Cloud: Implementing exponential backoff
【689】 Martin Fowler: CircuitBreaker
【690】 AWS Well-Architected Framework: REL05-BP04 Bulkhead architecture
【691】 OpenAI: Structured Outputs
【692】 Anthropic: Tool use with Claude
【693】 JSON Schema Specification
【694】 Pydantic: Validators
【695】 OpenAI: Moderation API
【696】 Anthropic: Guardrails against misuse
【697】 Google Cloud: Responsible AI practices
【698】 OpenAI Evals
【699】 OpenAI: Evaluation best practices
【700】 OpenAI: 2026-06-03 Evals platform deprecation
【701】 SciPy: Binomial proportion confidence intervals
【703】 Braintrust: What is an eval?
【704】 LangSmith: Evaluation concepts
【705】 OpenTelemetry: Semantic conventions for generative AI systems
【706】 Google SRE Book: Monitoring Distributed Systems
【707】 Arize Phoenix: Tracing
【708】 Honeycomb: Observability for LLMs
【709】 OpenAI: GPT-4o snapshots
【710】 OpenAI: Deprecations
【711】 DVC: Data Version Control
【712】 MLflow: Model Registry
【713】 Google SRE Workbook: Canarying Releases
【714】 SciPy: ttest_ind,独立样本与 Welch 检验前提
【715】 Spinnaker: Canary Analysis
【716】 Optimizely: Statistical significance in A/B testing
【717】 OpenAI: Prompt caching
【718】 OpenAI: Batch API
【719】 Anthropic: Message Batches API
【720】 Google Cloud: Cost optimization for AI and ML workloads
【721】 Google SRE Book: Service Level Objectives
【722】 Google SRE Workbook: Implementing SLOs
【723】 OpenAI: Rate limits
【724】 Anthropic: Rate limits
【725】 PagerDuty: Incident Response Documentation
【726】 OpenAI: Fine-tuning
【727】 Anthropic: Constitutional AI and RLHF
【728】 Netflix Tech Blog: Recommendation systems and the data flywheel
【729】 Google: People + AI Guidebook - Feedback + Control
【730】 MITRE ATLAS
【731】 NIST Generative AI Profile (NIST AI 600-1)
【732】 OWASP Agentic AI Threats and Mitigations
【733】 OWASP Top 10 for Agentic Applications 2026
【734】 NIST AI 100-2 E2025: Adversarial Machine Learning Taxonomy
【735】 OWASP LLM01:2025 Prompt Injection
【736】 OWASP LLM07:2025 System Prompt Leakage
【737】 Many-shot Jailbreaking (Anthropic)
【738】 Universal and Transferable Adversarial Attacks on Aligned Language Models
【739】 Ignore This Title and HackAPrompt: Exposing Systemic Vulnerabilities of LLMs
【740】 MITRE ATLAS: Prompt Injection
【741】 OWASP LLM05:2025 Improper Output Handling
【742】 OWASP LLM02:2025 Sensitive Information Disclosure
【743】 Imprompter: Tricking LLM Agents into Improper Tool Use
【744】 OWASP: CSV Injection
【745】 Poisoning Web-Scale Training Datasets is Practical
【746】 Anthropic / UK AISI / Alan Turing Institute: Small samples can poison language models
【747】 BadNets: Identifying Vulnerabilities in the Machine Learning Model Supply Chain
【748】 A Backdoor Attack Against LSTM-based Text Classification Systems
【749】 On the Exploitability of Instruction Tuning
【750】 OWASP LLM04:2025 Data and Model Poisoning
【751】 OWASP LLM03:2025 Supply Chain
【752】 Hugging Face: Pickle Scanning and Safetensors
【753】 PyTorch 2.6: Serialization semantics and weights_only
【754】 Sleepy Pickle: Exploiting Machine Learning Pickle Files
【755】 MITRE ATLAS: ML Supply Chain Compromise
【756】 CycloneDX: Machine Learning Bill of Materials (ML-BOM)
【757】 Sigstore: Software Signing for Everyone
【758】 Extracting Training Data from Large Language Models
【759】 Quantifying Memorization Across Neural Language Models
【760】 Membership Inference Attacks against Machine Learning Models
【761】 Deep Learning with Differential Privacy (DP-SGD)
【762】 GDPR 原文:第 5、6、17 条及第五章
【763】 Confused Deputy Problem (Norm Hardy, 1988)
【764】 RFC 8693: OAuth 2.0 Token Exchange,尤其 1.1、4.1 节
【765】 RFC 7662: OAuth 2.0 Token Introspection
【766】 NIST SP 800-207: Zero Trust Architecture
【767】 SPIFFE/SPIRE: Workload Identity Framework
【768】 OWASP LLM06:2025 Excessive Agency
【769】 gVisor: Application Kernel for Containers
【770】 Firecracker: Secure and Fast microVMs
【771】 MDN: Same-origin policy
【772】 Anthropic: Computer Use Demo — security precautions and isolation limitations
【773】 garak: LLM Vulnerability Scanner
【774】 PyRIT: Python Risk Identification Tool for generative AI
【775】 HarmBench: A Standardized Evaluation Framework for Automated Red Teaming
【776】 Red Teaming Language Models with Language Models
【777】 OWASP LLM Applications Cybersecurity and Governance Checklist
【778】 EU AI Act:Regulation (EU) 2024/1689 原文
【779】 Regulation (EU) 2026/1744:第 1 条 (39)、(40) 项与第 4 条
【780】 European Commission: AI Act policy overview
【781】 C2PA 2.2: Explainer,验证能力与非目标
【782】 Model Cards for Model Reporting
【783】 System Cards: A New Resource for Understanding How AI Systems Work
【784】 Palantir:Dev versus Delta——工程角色的区别
【785】 Palantir:A Day in the Life of a Forward Deployed Software Engineer
【786】 Palantir:AIP Chatbot Studio 概览
【787】 Palantir:Security and governance
【788】 OpenAI Deployment Company:Build, Prove, Generalize
【789】 OpenAI:Forward Deployed Engineer, Gov
【790】 OpenAI:Production best practices
【791】 Anthropic:How we built Claude Managed Agents
【792】 Palantir:Securing Software at the Speed of AI(官方工程案例,2026)
【793】 Microsoft:Only Believe What You Can Validate(客户现场工程分享,2026)
【794】 Baseten:Forward Deployed Engineering on the Frontier of AI(官方团队实践,2025)
【795】 AWS 与 INRIX:交通规划 PoC 实践(客户与厂商共同撰写,2025)
【796】 @vasuman:Forward Deployed Engineering 101(X 一线从业者长文)
【797】 Hamel Husain:A Field Guide to Rapidly Improving AI Products
【798】 Varick Agents:Careers
【799】 run_maotui:产品工作中的 AI 协作分享
【800】 Applied AI Field Guide
【801】 五分钟导读
【802】 FDEstack
【803】 八个 Skills 的总览
【804】 OpenFDE
【805】 架构说明
【806】 FDEOps
【807】 项目总览
【808】 发票异常教学案例
【809】 hold-scope
【810】 unknowns.md
【811】 /poc
【812】 /integrate
【813】 交接流程
【814】 eval 命令
【815】 任务状态转换
【816】 交接案例
【817】 模式整理
【818】 Claude 抽取实现
【819】 隐私说明
各章阅读说明¶
- BERT: Pre-training of Deep Bidirectional Transformers for Language Understanding【1】
- Language Models are Few-Shot Learners(GPT-3)【2】
- Language Models are Unsupervised Multitask Learners(GPT-2)【3】
- Emergent Abilities of Large Language Models【4】
- Are Emergent Abilities of Large Language Models a Mirage?【5】
- Scaling Laws for Neural Language Models【6】
- Training Compute-Optimal Large Language Models(Chinchilla)【7】
- The Llama 3 Herd of Models【8】
- Attention Is All You Need【9】
- BERT【1】
- Exploring the Limits of Transfer Learning with a Unified Text-to-Text Transformer(T5)【10】
- On Layer Normalization in the Transformer Architecture【11】
- Root Mean Square Layer Normalization【12】
- GLU Variants Improve Transformer【13】
- Query-Key Normalization for Transformers【14】
- Transformer Feed-Forward Layers Are Key-Value Memories【15】
第三章:MHA 的局限与 MQA、GQA、Flash Attention
- Fast Transformer Decoding: One Write-Head is All You Need(MQA)【16】
- GQA: Training Generalized Multi-Query Transformer Models from Multi-Head Checkpoints【17】
- Llama 2【18】
- The Llama 3 Herd of Models【8】
- DeepSeek-V2 论文与官方实现【19】
- FlashAttention【20】
- FlashAttention 官方仓库与版本要求(2026-07-06 README 快照)【21】
- Online normalizer calculation for softmax【22】
- Mistral 7B【23】
- Linformer【24】
- Rethinking Attention with Performers【25】
- Mamba: Linear-Time Sequence Modeling with Selective State Spaces【26】
- Attention Is All You Need【9】
- RoFormer: Enhanced Transformer with Rotary Position Embedding【27】
- ALiBi: Train Short, Test Long【28】
- Position Interpolation【29】
- YaRN: Efficient Context Window Extension of Large Language Models【30】
- Hugging Face Transformers:RoPE 参数与变体【31】
- BLOOM 模型卡【32】
- MosaicML:MPT-7B 发布说明与 ALiBi 配置【33】
- Lost in the Middle: How Language Models Use Long Contexts【34】
- Neural Machine Translation of Rare Words with Subword Units(BPE)【35】
- SentencePiece: A simple and language independent subword tokenizer【36】
- Subword Regularization: Improving NMT Models with Multiple Subword Candidates(Unigram)【37】
- Hugging Face: Tokenizers 教程【38】
- OpenAI tiktoken【39】
- The Llama 3 Herd of Models【8】
- Meta Llama 3 Tokenizer 官方实现【40】
- Google SentencePiece 官方实现与配置说明【41】
- Hugging Face Transformers:Tokenization algorithms【42】
- Hugging Face Transformers:Chat templates【43】
- GPT-3,§2 与 few-shot 评估【44】
- Llama 2,§2.1、§3.1.1 与模型卡【45】
- The Llama 3 Herd of Models,§3、§4【46】
- Chinchilla:训练计算量近似【47】
- InstructGPT【48】
- LIMA【49】
- Deep Reinforcement Learning from Human Preferences【50】
- DPO:奖励重参数化与偏好损失【51】
- DeepSeek-R1,2025 年初版训练流程【52】
- Scaling Laws for Neural Language Models【6】
- Chinchilla:§3、表 2 与计算最优推导【47】
- Emergent Abilities of Large Language Models【4】
- Are Emergent Abilities of Large Language Models a Mirage?【5】
- The Llama 3 Herd of Models【46】
- Qwen3 Technical Report,初版【53】
- DeepSeekMath:数据构建与 GRPO【54】
- DeepSeek-R1,初版【52】
- LoRA【55】
- QLoRA【56】
- Transformers v4.46.3:Model training anatomy【57】
- PEFT:LoRA 配置与初始化【58】
- DPO【51】
- LIMA【49】
- LoRA:公式、初始化与 rank 实验【55】
- QLoRA【56】
- Parameter-Efficient Transfer Learning for NLP【59】
- PEFT v0.17.0:LoRA 配置、初始化与缩放【60】
- PEFT:Model merging 与 add_weighted_adapter【61】
- PEFT v0.17.0:加权 adapter 的实现与限制【62】
- vLLM:LoRA adapters【63】
- Transformers:模型训练的内存组成【57】
- InstructGPT【48】
- Deep Reinforcement Learning from Human Preferences【50】
- DPO【51】
- DeepSeekMath:GRPO 与迭代训练【54】
- DeepSeek-R1:初版 §2【52】
- Llama 2【45】
- The Llama 3 Herd of Models【46】
- Constitutional AI【64】
- RLAIF vs. RLHF【65】
- Proximal Policy Optimization Algorithms【66】
- Proximal Policy Optimization Algorithms【66】
- OpenAI Spinning Up:PPO-Clip 公式与约束边界【67】
- InstructGPT【48】
- DPO:§4 与附录 A 推导【51】
- DeepSeekMath:GRPO【54】
- DeepSeek-R1,初版【52】
- Llama 2【45】
- The Llama 3 Herd of Models【46】
- High-Dimensional Continuous Control Using Generalized Advantage Estimation【68】
- The Curious Case of Neural Text Degeneration【69】
- If Beam Search Is the Answer, What Was the Question?【70】
- Fast Inference from Transformers via Speculative Decoding【71】
- Self-Consistency Improves Chain of Thought Reasoning in Language Models【72】
- PagedAttention:包含 beam search 的缓存共享设计【73】
- Qwen3-30B-A3B 官方模型卡【74】
- vLLM:Batch Invariance【75】
第十三章:Temperature、Top-P、Top-K 调参
- The Curious Case of Neural Text Degeneration【69】
- Transformers:Generation Utilities,含 Temperature/TopK/TopP LogitsWarper【76】
- Transformers v4.56.2:贪心、采样与束搜索的配置条件【77】
- Qwen3-30B-A3B 官方模型卡与采样建议【74】
- vLLM:Batch Invariance【75】
第十四章:KV Cache 与 Prompt Caching
- PagedAttention 原论文【73】
- MQA 原论文【16】
- GQA 原论文【17】
- Anthropic 官方 Prompt Caching cookbook【78】
- Anthropic 官方 SDK:缓存 TTL 类型【79】
- OpenAI:Prompt Caching【80】
- KIVI 原论文【81】
- vLLM:Automatic Prefix Caching 设计【82】
接口资料核对范围:2026-09-08 的官方文档与 SDK;OpenAI 缓存指南另于 2026-09-15 复核。示例没有发起计费请求,不代表一次真实缓存命中结果。
- GPTQ: Accurate Post-Training Quantization for Generative Pre-trained Transformers【83】
- AWQ: Activation-aware Weight Quantization for LLM Compression and Acceleration【84】
- QLoRA: Efficient Finetuning of Quantized LLMs(NF4)【56】
- LLM.int8(): 8-bit Matrix Multiplication for Transformers at Scale【85】
- SmoothQuant: Accurate and Efficient Post-Training Quantization for Large Language Models【86】
- Optimal Brain Compression: A Framework for Accurate Post-Training Quantization and Pruning【87】
- llama.cpp / GGUF【88】
- AutoAWQ【89】
- GPTQ 作者实现:列顺序、act-order 与分组【90】
- AWQ 原论文:逐通道缩放与搜索【91】
- PyTorch AO:Quantization-Aware Training【92】
- FP8 Formats for Deep Learning,v1,第 2–3 节与表 1【93】
- OCP Microscaling Formats (MX) Specification v1.0【94】
- 微软 MX 库:最大指数缩放与 scale 边界,固定版本【95】
- NVIDIA:Introducing NVFP4 for Efficient and Accurate Low-Precision Inference【96】
- NVIDIA Transformer Engine:FP8 入门与 MXFP8/NVFP4,固定版本 notebook【97】
- NVIDIA Transformer Engine:缩放配方、历史最大值与 margin,固定版本源码【98】
- gpt-oss-120b 与 gpt-oss-20b 模型卡,v1,第 2.1 节与表 1:MXFP4 MoE 权重与 checkpoint 大小【99】
- AMD ROCm 博客:CDNA3 与 CDNA4 上的 FP8 FNUZ 与 OCP 变体【100】
- ONNX:FP8 正规数/次正规数解码与特殊值编码【101】
- vLLM v0.10.2:E4M3FN 到 E4M3FNUZ 的规范化,固定版本实现【102】
- Language Models are Few-Shot Learners(GPT-3,Few-shot)【2】
- Calibrate Before Use: Improving Few-Shot Performance of Language Models(示例与顺序偏差)【103】
- Chain-of-Thought Prompting Elicits Reasoning in Large Language Models【104】
- Large Language Models are Zero-Shot Reasoners(Let's think step by step)【105】
- LLMLingua: Compressing Prompts for Accelerated Inference of Large Language Models【106】
- LongLLMLingua: Accelerating and Enhancing LLMs in Long Context Scenarios via Prompt Compression【107】
- The Power of Scale for Parameter-Efficient Prompt Tuning(Soft Prompt)【108】
- OpenAI: Reasoning best practices(含分隔符与 CoT 提示的适用边界)【109】
- OpenAI: Structured Outputs【110】
- Chain-of-Thought Prompting Elicits Reasoning in Large Language Models【104】
- Large Language Models are Zero-Shot Reasoners(Let's think step by step)【105】
- Self-Consistency Improves Chain of Thought Reasoning in Language Models【72】
- Least-to-Most Prompting Enables Complex Reasoning in Large Language Models【111】
- Tree of Thoughts: Deliberate Problem Solving with Large Language Models【112】
- Towards Understanding Chain-of-Thought Prompting: An Empirical Study of What Matters【113】
- Measuring Faithfulness in Chain-of-Thought Reasoning【114】
- s1: Simple test-time scaling【115】
- Do NOT Think That Much for 2+3=? On the Overthinking of o1-Like LLMs【116】
- OpenAI: Reasoning best practices【109】
- OpenAI: Reasoning models【117】
- Anthropic Python SDK: 手动 thinking 配置【118】
- Amazon Bedrock: Extended thinking【119】(包含 Bedrock 上的手动预算规则、interleaved thinking 例外及模型差异,不代表所有 Claude 入口行为相同)
- On Faithfulness and Factuality in Abstractive Summarization【120】
- Survey of Hallucination in Natural Language Generation【121】
- A Survey on Hallucination in Large Language Models: Principles, Taxonomy, Challenges, and Open Questions【122】
- Language Models (Mostly) Know What They Know【123】
- TruthfulQA: Measuring How Models Mimic Human Falsehoods【124】
- Retrieval-Augmented Generation for Knowledge-Intensive NLP Tasks【125】
- SelfCheckGPT: Zero-Resource Black-Box Hallucination Detection for Generative Large Language Models【126】
- Chain-of-Verification Reduces Hallucination in Large Language Models【127】
- Constitutional AI: Harmlessness from AI Feedback【64】
- Towards Understanding Sycophancy in Language Models【128】
- OpenAI: Structured Outputs(结构保证与内容错误的区别)【110】
- Sparsely-Gated Mixture-of-Experts Layer【129】
- GShard【130】
- Switch Transformers【131】
- Mixtral of Experts【132】
- DeepSeek-V3 Technical Report【133】
- Auxiliary-Loss-Free Load Balancing【134】
- Expert Choice Routing【135】
- ST-MoE:Router z-loss【136】
- Qwen3-30B-A3B 官方模型卡【74】
- Efficient Memory Management for Large Language Model Serving with PagedAttention(vLLM)【73】
- SGLang: Efficient Execution of Structured Language Model Programs(RadixAttention)【137】
- Orca: A Distributed Serving System for Transformer-Based Generative Models(Continuous Batching)【138】
- vLLM 文档【139】
- vLLM: Automatic Prefix Caching【140】
- SGLang 仓库【141】
- Text Generation Inference 仓库【142】
- TGI 官方文档(维护模式说明,2026-09-15 核对)【143】
- llama.cpp 仓库【88】
- TensorRT-LLM 仓库【144】
- llama.cpp:HTTP Server 能力与参数【145】
- TensorRT-LLM:Quick Start【146】
- vLLM:Chunked Prefill 与配置调优【147】
- vLLM:Disaggregated Prefilling【148】
- TGI:组件与 HTTP/gRPC 边界【149】
- TensorRT-LLM:LLM API 与 PyTorch backend【150】
- Measuring Massive Multitask Language Understanding(MMLU)【151】
- MMLU-Pro: A More Robust and Challenging Multi-Task Language Understanding Benchmark【152】
- Evaluating Large Language Models Trained on Code(HumanEval / Pass@k)【153】
- SWE-bench: Can Language Models Resolve Real-World GitHub Issues?【154】
- OpenAI: Why SWE-bench Verified no longer measures frontier coding capabilities【155】
- Training Verifiers to Solve Math Word Problems(GSM8K)【156】
- Measuring Mathematical Problem Solving With the MATH Dataset【157】
- GPQA: A Graduate-Level Google-Proof Q&A Benchmark【158】
- Judging LLM-as-a-Judge with MT-Bench and Chatbot Arena【159】
- Holistic Evaluation of Language Models(HELM)【160】
- LiveBench: A Challenging, Contamination-Limited LLM Benchmark【161】
- tau-bench: A Benchmark for Tool-Agent-User Interaction in Real-World Domains【162】
- HumanEval 官方 Pass@k 实现【163】
- SWE-bench 官方文档(Verified 子集)【164】
- Humanity's Last Exam【165】
- On Faithfulness and Factuality in Abstractive Summarization(词面指标与忠实性的区别)【120】
- Holistic Evaluation of Language Models(HELM)【160】
- Judging LLM-as-a-Judge with MT-Bench and Chatbot Arena【159】
- DeepSeek-V3 Technical Report【166】
- Qwen3 Technical Report【167】
- tau-bench: A Benchmark for Tool-Agent-User Interaction in Real-World Domains【162】
- RouteLLM: Learning to Route LLMs with Preference Data【168】
- FrugalGPT: How to Use Large Language Models While Reducing Cost and Improving Performance【169】
- OpenAI: Data controls in the OpenAI platform【170】
- OpenAI: Structured Outputs【110】
- CLIP: Learning Transferable Visual Models From Natural Language Supervision【171】
- Flamingo: a Visual Language Model for Few-Shot Learning【172】
- LLaVA: Visual Instruction Tuning【173】
- Whisper: Robust Speech Recognition via Large-Scale Weak Supervision【174】
- Video-LLaMA: An Instruction-tuned Audio-Visual Language Model【175】
- NIST AI Risk Management Framework【176】
- BLIP-2: Bootstrapping Language-Image Pre-training with Frozen Image Encoders and Large Language Models【177】
- Qwen2-VL: Enhancing Vision-Language Model's Perception of the World at Any Resolution【178】
- Hugging Face Evaluate:WER 指标定义与实现说明【179】
- CLIP: Learning Transferable Visual Models From Natural Language Supervision【171】
- Sigmoid Loss for Language Image Pre-Training (SigLIP)【180】
- ImageBind: One Embedding Space To Bind Them All【181】
- Flamingo: a Visual Language Model for Few-Shot Learning【172】
- Perceiver IO: A General Architecture for Structured Inputs & Outputs【182】
- LLaVA: Visual Instruction Tuning【173】
- Qwen-VL:位置感知视觉语言适配器【183】
- Chameleon: Mixed-Modal Early-Fusion Foundation Models【184】
- Neural Discrete Representation Learning (VQ-VAE)【185】
- Taming Transformers for High-Resolution Image Synthesis (VQGAN)【186】
- OpenAI GPT-4o System Card【187】
- GPT-4o System Card(原始报告)【188】
- Grounding DINO: Marrying DINO with Grounded Pre-Training for Open-Set Object Detection【189】
- Grounded Language-Image Pre-training (GLIP)【190】
- Simple Open-Vocabulary Object Detection with Vision Transformers (OWL-ViT)【191】
- PaliGemma: A versatile 3B VLM for transfer【192】
- Qwen-VL: A Versatile Vision-Language Model【183】
- Molmo and PixMo: Open Weights and Open Data for State-of-the-Art Multimodal Models【193】
- Visual Genome: Connecting Language and Vision Using Crowdsourced Dense Image Annotations【194】
- Generation and Comprehension of Unambiguous Object Descriptions(RefCOCOg)【195】
- ReferItGame: Referring to Objects in Photographs of Natural Scenes【196】
- REFER:数据集来源与划分说明【197】
- LayoutLM: Pre-training of Text and Layout for Document Image Understanding【198】
- LayoutLMv3: Pre-training for Document AI with Unified Text and Image Masking【199】
- OCR-free Document Understanding Transformer (Donut)【200】
- PubTables-1M: Towards Comprehensive Table Extraction From Unstructured Documents【201】
- GriTS: Grid Table Similarity【202】
- Image-based table recognition: data, model, and evaluation (PubTabNet / TEDS)【203】
- ChartQA: A Benchmark for Question Answering about Charts【204】
- DocVQA: A Dataset for VQA on Document Images【205】
- Azure AI Document Intelligence 官方文档【206】
- Azure Document Intelligence:准确率与置信度【207】
- Google Cloud Document AI 官方文档【208】
- Amazon Textract 官方文档【209】
- Amazon Textract:AnalyzeDocument 与 FeatureTypes【210】
- Anthropic: Developing a computer use model【211】
- Anthropic:升级版 Claude 3.5 Sonnet 与 Computer Use 公开测试【212】
- Anthropic Computer Use 官方文档【213】
- OpenAI: Computer-Using Agent【214】
- OpenAI Operator【215】
- OpenAI:Computer Use 工具与执行环境【216】
- UI-TARS: Pioneering Automated GUI Interaction with Native Agents【217】
- OSWorld: Benchmarking Multimodal Agents for Open-Ended Tasks in Real Computer Environments【218】
- WebArena: A Realistic Web Environment for Building Autonomous Agents【219】
- Whisper: Robust Speech Recognition via Large-Scale Weak Supervision【174】
- Connectionist Temporal Classification(原论文)【220】
- Sequence Transduction with Recurrent Neural Networks (RNN-T)【221】
- Natural TTS Synthesis by Conditioning WaveNet on Mel Spectrogram Predictions (Tacotron 2)【222】
- Neural Codec Language Models are Zero-Shot Text to Speech Synthesizers (VALL-E)【223】
- SoundStream: An End-to-End Neural Audio Codec【224】
- High Fidelity Neural Audio Compression (EnCodec)【225】
- AudioLM: a Language Modeling Approach to Audio Generation【226】
- Qwen-Audio: Advancing Universal Audio Understanding via Unified Large-Scale Audio-Language Models【227】
- SALMONN: Towards Generic Hearing Abilities for Large Language Models【228】
- Moshi: a speech-text foundation model for real-time dialogue【229】
- Generative Spoken Dialogue Language Modeling (dGSLM)【230】
- OpenAI GPT-4o System Card【187】
- GPT-4o System Card(原始报告)【188】
- OpenAI Realtime API 官方文档【231】
- OpenAI Realtime:会话状态与打断处理【232】
- Kyutai Moshi 项目主页【233】
- Denoising Diffusion Probabilistic Models (DDPM)【234】
- Denoising Diffusion Implicit Models (DDIM)【235】
- Score-Based Generative Modeling through Stochastic Differential Equations【236】
- High-Resolution Image Synthesis with Latent Diffusion Models (Stable Diffusion)【237】
- Classifier-Free Diffusion Guidance【238】
- Flow Matching for Generative Modeling【239】
- Flow Straight and Fast: Learning to Generate and Transfer Data with Rectified Flow【240】
- Scaling Rectified Flow Transformers for High-Resolution Image Synthesis (Stable Diffusion 3)【241】
- Photorealistic Text-to-Image Diffusion Models with Deep Language Understanding (Imagen)【242】
- OpenAI DALL·E 3: Improving Image Generation with Better Captions【243】
- GANs Trained by a Two Time-Scale Update Rule Converge to a Local Nash Equilibrium (FID)【244】
- CLIPScore: A Reference-free Evaluation Metric for Image Captioning【245】
- Video Diffusion Models【246】
- Imagen Video: High Definition Video Generation with Diffusion Models【247】
- OpenAI: Video generation models as world simulators (Sora 技术报告)【248】
- Stable Video Diffusion: Scaling Latent Video Diffusion Models to Large Datasets【249】
- Towards Accurate Generative Models of Video: A New Metric & Challenges (FVD)【250】
- VBench: Comprehensive Benchmark Suite for Video Generative Models【251】
- LAION-5B: An Open Large-Scale Dataset for Training Next Generation Image-Text Models【252】
- OpenAI DALL·E 3: Improving Image Generation with Better Captions【243】
- LLaVA: Visual Instruction Tuning【173】
- Flamingo: a Visual Language Model for Few-Shot Learning【172】
- OBELICS: An Open Web-Scale Filtered Dataset of Interleaved Image-Text Documents【253】
- Aligning Large Multimodal Models with Factually Augmented RLHF (LLaVA-RLHF)【254】
- MMMU: A Massive Multi-discipline Multimodal Understanding and Reasoning Benchmark【255】
- MathVista: Evaluating Mathematical Reasoning of Foundation Models in Visual Contexts【256】
- Multimodal Neurons in Artificial Neural Networks (Typographic Attack)【257】
- Visual Adversarial Examples Jailbreak Aligned Large Language Models【258】
- C2PA 2.1 技术规范【259】
- Google DeepMind: SynthID【260】
- DistServe: Disaggregating Prefill and Decoding for Goodput-optimized Large Language Model Serving【261】
- vLLM:前缀缓存设计与多模态哈希【82】
第一章:Function Calling 是什么,原理是什么
- OpenAI: Function Calling 指南(2026-09-08 核查)【262】
- OpenAI: Responses API 迁移指南(本节字段与示例于 2026-09-16 对照此页及 Function Calling 指南核查)【263】
- OpenAI: 2023 年 Function Calling 发布【264】
- Anthropic: Tool Use with Claude【265】
- Anthropic: Writing Effective Tools for Agents【266】
- Toolformer: Language Models Can Teach Themselves to Use Tools【267】
- ReAct: Synergizing Reasoning and Acting in Language Models【268】
- JSON Schema 规范【269】
- Toolformer: Language Models Can Teach Themselves to Use Tools【267】
- ReAct 原论文【268】
- PPO 原论文【66】
- ToolLLM: Facilitating Large Language Models to Master 16000+ Real-world APIs【270】
- Training language models to follow instructions with human feedback(InstructGPT)【48】
- Constitutional AI: Harmlessness from AI Feedback【64】
- ToolRL: Reward is All Tool Learning Needs【271】
- ReTool: Reinforcement Learning for Strategic Tool Use in LLMs【272】
- Berkeley Function Calling Leaderboard【273】
- API-Bank: A Comprehensive Benchmark for Tool-Augmented LLMs【274】
- τ-bench: A Benchmark for Tool-Agent-User Interaction in Real-World Domains【162】
- Anthropic: Writing Effective Tools for Agents【266】
- Anthropic: Building Effective Agents【275】
- OpenAI: Function Calling 指南【262】
- OpenAI: Structured Outputs 支持的 Schema【110】
- JSON Schema 规范【269】
- Berkeley Function Calling Leaderboard【273】
- 版本状态核对:2026-09-15 复核下列固定版变更与兼容说明;采用固定协议基准,不将动态页面的“最新”当作 SDK 已支持的证明。
- MCP 版本状态【276】
- MCP 2026-07-28 变更记录【277】
- Model Context Protocol 官方文档【278】
- MCP 规范 2026-07-28【279】
- MCP 版本兼容说明【280】
- MCP 架构说明【281】
- Anthropic: Introducing the Model Context Protocol【282】
- JSON-RPC 2.0 规范【283】
- MCP 架构说明【281】
- MCP 规范 2026-07-28【279】
- MCP Server 能力:Tools【285】
- MCP Multi Round-Trip Requests【286】
- MCP 弃用特性【287】
- MCP 传输层规范【288】
- JSON-RPC 2.0 规范【283】
第六章:MCP 与 Function Calling 的区别与选型
- Model Context Protocol 官方文档【278】
- MCP 服务端开发快速上手【290】
- MCP Servers 官方示例仓库【291】
- 已归档 MCP 示例【292】
- MCP Roots:弃用状态与非安全边界【293】
- OpenAI: Function Calling 指南【294】
- Anthropic: Introducing the Model Context Protocol【282】
- OpenAI: Reasoning Models 指南【117】
- OpenAI: Function Calling 与 reasoning 项回传【262】
- OpenAI: o1-preview 模型页【295】
- OpenAI: o1 模型与快照【296】
- OpenAI Cookbook:o1-preview 初期结构化输出限制【297】
- Anthropic:Claude 4 交错工具使用发布说明【298】
- Anthropic Cookbook:早期 Claude 3.7 thinking 块保留示例【299】
- Anthropic: Extended Thinking【300】
- DeepSeek-R1: Incentivizing Reasoning Capability in LLMs via Reinforcement Learning【301】
- ReTool: Reinforcement Learning for Strategic Tool Use in LLMs【272】
- ToolRL: Reward is All Tool Learning Needs【271】
- Efficient Memory Management for Large Language Model Serving with PagedAttention【73】
- 格式核查保留原有固定提交
69ef37e9424c0a7ea9dd2293b559e43ec8176379作为历史基准,并于 2026-09-15 复核官方格式页中的必填字段、实验性字段和加载建议;官方页没有独立的语义版本号。 - Anthropic: Introducing Agent Skills【302】
- Anthropic: Equipping Agents for the Real World with Agent Skills【303】
- Agent Skills 规范【304】
- Agent Skills 本次核查的固定提交【305】
- Claude Docs: Agent Skills【306】
- Anthropic: Building Effective Agents【275】
- Anthropic: Effective Context Engineering for AI Agents【307】
- Anthropic: Introducing Agent Skills【302】
- Agent Skills 规范【304】
- Model Context Protocol 官方文档【278】
- MCP 2026-07-28 工具发现与 Schema【285】
- Anthropic: Equipping Agents for the Real World with Agent Skills【303】
- Anthropic: Effective Context Engineering for AI Agents【307】
第十章:Function Calling、MCP、Skill 三者关系
- OpenAI: Function Calling 指南【294】
- Model Context Protocol 官方文档【278】
- MCP 规范 2026-07-28【279】
- Anthropic: Introducing Agent Skills【302】
- Agent Skills 规范【304】
- Anthropic: Building Effective Agents【275】
- 来源核对:2026-09-15 读取 v1.0.1 发布记录、规范和 Proto 定义。该标签内规范页仍有“Latest Released Version 1.0.0”的旧提示;Send Message 概述中的立即返回措辞,也与执行模式小节和 Proto 的默认阻塞定义不一致。本章按后两处明确的
return_immediately字段定义说明,线上 JSON 使用returnImmediately。 - A2A v1.0.1 发布记录【309】
- A2A 协议官网【310】
- A2A v1.0.1 发布规范【311】
- A2A v1.0.1 规范数据定义【312】
- Google: Announcing the Agent2Agent Protocol【313】
- Linux Foundation: A2A Project【314】
- Model Context Protocol 官方文档【278】
- Anthropic: Building Effective Agents【275】
- MCP 规范 2026-07-28:Transports【288】
- MCP 2026-07-28 Streamable HTTP【315】
- MCP 2026-07-28 stdio【316】
- MCP 2026-07-28 版本兼容【280】
- MCP 规范 2025-03-26(Streamable HTTP 引入版本)【317】
- JSON-RPC 2.0 规范【283】
- MCP 官方 Server 集合【291】
- MDN: Server-Sent Events【318】
- MDN: Using Server-Sent Events【318】
- MDN: The WebSocket API【319】
- MDN: WebRTC API【320】
- RFC 6455: The WebSocket Protocol【321】
- RFC 8445: Interactive Connectivity Establishment (ICE)【322】
- WebRTC 官方站点【323】
- WHATWG HTML:Server-sent events【324】
- RFC 8835:WebRTC 传输【325】
- RFC 8834:WebRTC 媒体与丢包恢复【326】
- RFC 8831:WebRTC Data Channels【327】
- RFC 8441:WebSocket over HTTP/2【328】
- RFC 9220:WebSocket over HTTP/3【329】
- OpenAI: WebRTC 接入(Realtime API 部分)【330】
- MCP 规范:Transports【288】
- A2A v1.0.1 发布规范【311】
- LiteLLM 文档【332】
- LiteLLM GitHub【333】
- Bifrost 官方仓库(Go 实现)【334】
- LiteLLM 重试与故障转移【335】
- RFC 9111:HTTP 缓存【336】
- Portkey AI Gateway【337】
- Kong AI Gateway【338】
- Envoy AI Gateway【339】
- Langfuse: LLM 可观测性【340】
- OWASP Top 10 for LLM Applications【341】
- MCP 2026-07-28 Authorization【342】
- MCP 2026-07-28 Security Best Practices【343】
- MCP 2026-07-28 Transports【288】
- A2A v1.0.1 发布规范【311】
- RFC 9728: OAuth 2.0 Protected Resource Metadata【344】
- RFC 8252: 原生应用 OAuth 与 loopback 回调【345】
- RFC 9700: OAuth 2.0 Security Best Current Practice【346】
- RFC 7636: PKCE【347】
- RFC 8707: Resource Indicators for OAuth 2.0【348】
- Retrieval-Augmented Generation for Knowledge-Intensive NLP Tasks【125】
- Dense Passage Retrieval for Open-Domain Question Answering【349】
- Retrieval-Augmented Generation for Large Language Models: A Survey【350】
- Searching for Best Practices in Retrieval-Augmented Generation【351】
- Anthropic: Introducing Contextual Retrieval【352】
- Lost in the Middle: How Language Models Use Long Contexts【34】
- Chroma Research: Context Rot — How Increasing Input Tokens Impacts LLM Performance【353】
- Can Long-Context Language Models Subsume Retrieval, RAG, SQL, and More?【354】
- Long-Context LLMs Meet RAG: Overcoming Challenges for Long Inputs in RAG【355】
- LongRAG: Enhancing Retrieval-Augmented Generation with Long-context LLMs【356】
- RAFT: Adapting Language Model to Domain Specific RAG【357】
- Anthropic: Introducing Contextual Retrieval【352】
- ColPali: Efficient Document Retrieval with Vision Language Models【358】
- Qdrant:Payload 更新与索引【359】
- Advanced ingestion process powered by LLM parsing for RAG system【360】
- Searching for Best Practices in Retrieval-Augmented Generation【351】
- Retrieval-Augmented Generation for Large Language Models: A Survey【350】
- Searching for Best Practices in Retrieval-Augmented Generation【351】
- Dense X Retrieval: What Retrieval Granularity Should We Use?【361】
- Qwen3-Embedding-0.6B 模型卡【362】
- Anthropic: Introducing Contextual Retrieval【352】
- Retrieval-Augmented Generation for Large Language Models: A Survey【350】
- Anthropic: Introducing Contextual Retrieval【352】
- Late Chunking: Contextual Chunk Embeddings Using Long-Context Embedding Models【363】
- Jina AI:Late Chunking 的编码后池化与边界说明【364】
- Dense X Retrieval: What Retrieval Granularity Should We Use?【361】
- RAPTOR: Recursive Abstractive Processing for Tree-Organized Retrieval【365】
- Searching for Best Practices in Retrieval-Augmented Generation【351】
- Efficient Estimation of Word Representations in Vector Space【367】
- Stanford GloVe:全局共现统计与加权最小二乘目标【368】
- BERT: Pre-training of Deep Bidirectional Transformers for Language Understanding【1】
- Sentence-BERT: Sentence Embeddings using Siamese BERT-Networks【369】
- SimCSE: Simple Contrastive Learning of Sentence Embeddings【370】
- Dense Passage Retrieval for Open-Domain Question Answering【349】
- ColBERTv2: Effective and Efficient Retrieval via Lightweight Late Interaction【371】
- ColPali: Efficient Document Retrieval with Vision Language Models【358】
- MTEB: Massive Text Embedding Benchmark【372】
- MMTEB: Massive Multilingual Text Embedding Benchmark【373】
- Matryoshka Representation Learning【374】
- OpenAI:New embedding models and API updates(2024-01-25)【375】
- OpenAI:Embedding API 与 dimensions 参数【376】
- Qwen3-Embedding-0.6B 模型卡【362】
- M3-Embedding: Multi-Linguality, Multi-Functionality, Multi-Granularity Text Embeddings Through Self-Knowledge Distillation【377】
- Searching for Best Practices in Retrieval-Augmented Generation【351】
- Efficient and robust approximate nearest neighbor search using Hierarchical Navigable Small World graphs【378】
- pgvector 官方 README:过滤、迭代扫描、VACUUM 与扩展【379】
- FreshDiskANN: A Fast and Accurate Graph-Based ANN Index for Streaming Similarity Search【380】
- ACORN: Performant and Predicate-Agnostic Search Over Vector Embeddings and Structured Data【381】
- Billion-scale similarity search with GPUs【382】
- Searching for Best Practices in Retrieval-Augmented Generation【351】
- Efficient and robust approximate nearest neighbor search using Hierarchical Navigable Small World graphs【378】
- hnswlib v0.8.0:内部 ID、底层邻接容量与载荷布局【383】
- pgvector:精确基线、过滤与迭代扫描【379】
- FreshDiskANN: A Fast and Accurate Graph-Based ANN Index for Streaming Similarity Search【380】
- Matryoshka Representation Learning【374】
- Searching for Best Practices in Retrieval-Augmented Generation【351】
- Retrieval-Augmented Generation for Large Language Models: A Survey【350】
- Searching for Best Practices in Retrieval-Augmented Generation【351】
- Lost in the Middle: How Language Models Use Long Contexts【34】
- Self-RAG: Learning to Retrieve, Generate, and Critique through Self-Reflection【384】
- Adaptive-RAG: Learning to Adapt Retrieval-Augmented Large Language Models through Question Complexity【385】
- Lucene 9.12 BM25Similarity:词频饱和、长度归一化与 IDF 实现【386】
- Dense Passage Retrieval for Open-Domain Question Answering【349】
- SPLADE: Sparse Lexical and Expansion Model for First Stage Ranking【387】
- Elastic:ELSER 官方文档【388】
- ColBERTv2: Effective and Efficient Retrieval via Lightweight Late Interaction【371】
- ColPali: Efficient Document Retrieval with Vision Language Models【358】
- Searching for Best Practices in Retrieval-Augmented Generation【351】
- Precise Zero-Shot Dense Retrieval without Relevance Labels【389】
- Take a Step Back: Evoking Reasoning via Abstraction in Large Language Models【390】
- Query Rewriting for Retrieval-Augmented Large Language Models【391】
- Adaptive-RAG: Learning to Adapt Retrieval-Augmented Large Language Models through Question Complexity【385】
- Searching for Best Practices in Retrieval-Augmented Generation【351】
- Reciprocal Rank Fusion outperforms Condorcet and individual Rank Learning Methods (SIGIR 2009)【392】
- Lucene 9.12:BM25Similarity 的具体计分实现【386】
- Anthropic: Introducing Contextual Retrieval【352】
- ColBERTv2: Effective and Efficient Retrieval via Lightweight Late Interaction【371】
- Searching for Best Practices in Retrieval-Augmented Generation【351】
- Retrieval-Augmented Generation for Large Language Models: A Survey【350】
- Searching for Best Practices in Retrieval-Augmented Generation【351】
- Retrieval-Augmented Generation for Large Language Models: A Survey【350】
- Anthropic: Introducing Contextual Retrieval【352】
- Evaluation of Retrieval-Augmented Generation: A Survey【393】
- Self-RAG: Learning to Retrieve, Generate, and Critique through Self-Reflection【384】
- Corrective Retrieval Augmented Generation【394】
- RAPTOR: Recursive Abstractive Processing for Tree-Organized Retrieval【365】
- Adaptive-RAG: Learning to Adapt Retrieval-Augmented Large Language Models through Question Complexity【385】
- Agentic Retrieval-Augmented Generation: A Survey on Agentic RAG【395】
- Active Retrieval Augmented Generation【396】
- Retrieval-Augmented Generation for Large Language Models: A Survey【350】
- From Local to Global: A Graph RAG Approach to Query-Focused Summarization【397】
- Microsoft GraphRAG 官方文档【398】
- Microsoft GraphRAG:索引方法【399】
- Microsoft GraphRAG:CLI(含更新方法)【400】
- Microsoft GraphRAG:查询模式【401】
- Microsoft GraphRAG:Local Search【402】
- LightRAG: Simple and Fast Retrieval-Augmented Generation【403】
- HippoRAG: Neurobiologically Inspired Long-Term Memory for Large Language Models【404】
- PathRAG: Pruning Graph-based Retrieval Augmented Generation with Relational Paths【405】
- Agentic Retrieval-Augmented Generation: A Survey on Agentic RAG【395】
微软在线文档查阅于 2026-09-15;CLI 选项与库实现会变化,复现时以锁定版本及其配置为准。
- Astute RAG: Overcoming Imperfect Retrieval Augmentation and Knowledge Conflicts for Large Language Models【406】
- Making Retrieval-Augmented Language Models Robust to Irrelevant Context【407】
- RAGAS: Automated Evaluation of Retrieval Augmented Generation【408】
- ALCE:Enabling Large Language Models to Generate Text with Citations【409】
- Corrective Retrieval Augmented Generation【394】
- Searching for Best Practices in Retrieval-Augmented Generation【351】
- Ragas: Automated Evaluation of Retrieval Augmented Generation【408】
- Ragas:Context Recall【410】
- Ragas:Context Precision【411】
- Ragas:Faithfulness【412】
- Ragas:Answer / Response Relevancy【413】
- ALCE:Enabling Large Language Models to Generate Text with Citations【409】
- Evaluation of Retrieval-Augmented Generation: A Survey【393】
- CRAG - Comprehensive RAG Benchmark【414】
- TREC RAG Track【415】
- Fact, Fetch, and Reason: A Unified Evaluation of Retrieval-Augmented Generation【416】
Ragas 在线指标文档查阅于 2026-09-15;文中的 API 名称用于区分统计口径,不代表所有历史版本都提供同名类。
- FreshDiskANN: A Fast and Accurate Graph-Based ANN Index for Streaming Similarity Search【380】
- pgvector 官方 README:更新、删除与 VACUUM【379】
- Efficient and robust approximate nearest neighbor search using Hierarchical Navigable Small World graphs【378】
- ACORN: Performant and Predicate-Agnostic Search Over Vector Embeddings and Structured Data【381】
- LightRAG: Simple and Fast Retrieval-Augmented Generation【403】
- Retrieval-Augmented Generation for Large Language Models: A Survey【350】
- PoisonedRAG: Knowledge Corruption Attacks to Retrieval-Augmented Generation of Large Language Models【417】
- Not what you've signed up for: Compromising Real-World LLM-Integrated Applications with Indirect Prompt Injection【418】
- Evaluation of Retrieval-Augmented Generation: A Survey【393】
- Searching for Best Practices in Retrieval-Augmented Generation【351】
- Retrieval-Augmented Generation for Large Language Models: A Survey【350】
- Learning Transferable Visual Models From Natural Language Supervision (CLIP)【171】
- ColPali: Efficient Document Retrieval with Vision Language Models【358】
- RAG-Anything: All-in-One RAG Framework【419】
- Retrieval-Augmented Generation for Knowledge-Intensive NLP Tasks【125】
- Not what you've signed up for: Compromising Real-World LLM-Integrated Applications with Indirect Prompt Injection【418】
- 李博杰,《深入理解 AI Agent》第五章:代码作为交互接口与生成 SQL 查询【420】。本章借鉴查询生成与执行的分工,业务、数据、SQL 与图为重新设计。
- 同一固定提交的 ERP 示例:README【421】、agent.py【422】、demo.py【423】。书中实验描述使用 PostgreSQL,配套运行示例使用 SQLite;这里核读源码,不运行上游程序,不引用其通过率为本章实验结论或客户收益。
- SQLite 官方:聚合函数【424】、URI 只读模式【425】、授权回调【426】、不可信 SQL 的安全措施【427】、应用函数安全【428】、执行计划【429】。
- SQLite 官方:类型亲和性【430】、STRICT 表及版本要求【431】。
- Safdarian 等,《SchemaGraphSQL:使用寻路图算法高效完成大规模数据库 Text-to-SQL Schema Linking》【432】,Findings of EACL 2026。本章采用它对 Schema 图寻路与可关联性发现的区分,不把论文基准结果当作生产保证。
- Nahid 等,《重新思考 Schema Linking:面向 Text-to-SQL 的上下文感知双向检索方法》【433】,Findings of EACL 2026。该研究支持把 Schema 检索单独评测,同时关注召回和误选。
资料查阅于 2026-09-14,2026-09-15 复核固定提交与 SQLite 类型、聚合及执行限制;英译于 2026-09-20 核查,Schema Linking 资料于 2026-09-29 复核。
- Anthropic: Introducing the Model Context Protocol【282】
- OpenAI Agents SDK: Agents【437】
- LangChain: Short-term memory【438】
- MCP joins the Agentic AI Foundation【439】
- Linux Foundation: Agent2Agent Protocol Project【314】
- A2A v1.0.1 发布规范:核心对象与消息发送【312】
- A2A Protocol: Core Concepts【440】
- Anthropic: Building Effective Agents【275】
- OpenAI: Function calling(Chat Completions 与 Responses 的工具定义、strict 模式)【262】
- MCP Governance and Stewardship【441】
- MCP joins the Agentic AI Foundation【439】
- Microsoft Agent Framework Overview【442】
- AutoGen Maintenance Mode【443】
- Anthropic: Effective context engineering for AI agents【307】
- Chroma Research: Context Rot — How Increasing Input Tokens Impacts LLM Performance【353】
- LangChain: Context Engineering for Agents【444】
- Drew Breunig: How Contexts Fail and How to Fix Them【445】
- Anthropic: Equipping agents for the real world with Agent Skills【303】
- Anthropic: Code execution with MCP【446】
- Cloudflare: Code Mode — the better way to use MCP【447】
- RAG-MCP: Mitigating Prompt Bloat in LLM Tool Selection via Retrieval-Augmented Generation【448】
第三章:Tools、Skills、Agents、Workflows 与 AGENTS.md
- Anthropic: Building Effective Agents【275】
- Model Context Protocol【278】
- Agent Skills Specification【304】
- AGENTS.md【449】
- OpenAI Codex: Custom instructions with AGENTS.md【450】
- OpenAI: Function calling【262】
Agent Skills 与宿主指令发现行为按 2026-09-15 查阅的官方页面核对;查阅日期不是格式版本号。
- ReAct: Synergizing Reasoning and Acting in Language Models【268】
- Reflexion: Language Agents with Verbal Reinforcement Learning【451】
- Reflexion 原文实验设置与表 1–2【452】
- ReWOO: Decoupling Reasoning from Observations for Efficient Augmented Language Models【453】
- An LLM Compiler for Parallel Function Calling【454】
- LangChain: Planning Agents【455】
- Anthropic: Building Effective Agents【275】
- Chain-of-Thought Prompting Elicits Reasoning in Large Language Models【104】
- Large Language Models are Zero-Shot Reasoners【105】
- Self-Consistency Improves Chain of Thought Reasoning in Language Models【72】
- Least-to-Most Prompting Enables Complex Reasoning in Large Language Models【111】
- Tree of Thoughts: Deliberate Problem Solving with Large Language Models【112】
- Graph of Thoughts: Solving Elaborate Problems with Large Language Models【457】
- PAL: Program-aided Language Models【458】
- Self-Refine: Iterative Refinement with Self-Feedback【459】
- Plan-and-Solve Prompting【460】
- Program of Thoughts Prompting【461】
- Language Models Don't Always Say What They Think: Unfaithful Explanations in Chain-of-Thought Prompting【462】
- Let's Verify Step by Step【463】
- DeepSeek-R1【301】
- Scaling LLM Test-Time Compute Optimally can be More Effective than Scaling Model Parameters【464】
- s1: Simple test-time scaling【115】
- OpenAI: Reasoning best practices【109】
- OpenAI: Reasoning models【117】
- Amazon Bedrock: Extended thinking【119】(thinking 返回形式与工具调用时的状态回传要求)
- Python 3.13: decimal — 精度、舍入与十进制计算【465】
- Anthropic: Building Effective Agents【275】
- LangChain: Planning Agents【455】
- LLMCompiler: An LLM Compiler for Parallel Function Calling【454】
- ReWOO: Decoupling Reasoning from Observations for Efficient Augmented Language Models【453】
- AWS Builders' Library: Making retries safe with idempotent APIs【466】
- SHOP 系列规划器:作者项目页与实现【467】
- Martin Kleppmann: How to do distributed locking(租约过期后的迟到写入与 fencing)【468】
- CoALA: Cognitive Architectures for Language Agents【469】
- MemGPT: Towards LLMs as Operating Systems【470】
- Generative Agents: Interactive Simulacra of Human Behavior【471】
- Reflexion: Language Agents with Verbal Reinforcement Learning【451】
- LangGraph: Memory overview【472】(文档快照 1fa2214【473】,用于区分 thread 与跨 thread 作用域)
- OpenAI: Safety in building agents【474】(引用信任边界原则,不依赖其中的产品默认模型建议)
- LongMemEval 论文【475】与官方说明快照 9e0b455【476】
- LoCoMo 论文【477】与ACL 2024 发布说明快照 9228632【478】
- LongMemEval-V2 官方说明快照 2cc8c54【479】
资料核对:2026-09-15。框架文档为滚动更新,上述快照固定本文引用的概念与评测说明,不代表已复现其基准结果。
- CoALA: Cognitive Architectures for Language Agents【469】
- MemGPT: Towards LLMs as Operating Systems【470】
- Generative Agents: Interactive Simulacra of Human Behavior【471】
- Reflexion: Language Agents with Verbal Reinforcement Learning【451】
- LangGraph: Persistence【483】(文档快照 3edafc8【484】)
- LangGraph: Checkpointers【485】
- LangGraph: Memory overview【472】(文档快照 1fa2214【473】)
- AWS Prescriptive Guidance:Transactional outbox pattern【486】(用于说明双写、重复投递与顺序问题,不代表任意队列具备端到端 exactly-once)
- etcd v3.5:事务比较与 revision【487】(一个支持原子条件更新的具体实现;其他数据库需核对各自保证)
- LongMemEval 官方说明快照 9e0b455【476】(区分原始版与 2025 年 9 月清洗版)
- LongMemEval-V2 官方说明快照 2cc8c54【479】
资料核对:2026-09-15;一致性、幂等和删除方案是设计建议,并非上述框架或任意向量库自动提供的保证。
第九章:Single-Agent 与 Multi-Agent 系统
- Anthropic: Building Effective Agents【275】
- Anthropic: How we built our multi-agent research system【488】
- Cognition: Don't Build Multi-Agents【489】
- Why Do Multi-Agent LLM Systems Fail? (MAST)【490】
- Agent2Agent (A2A) v1.0.1 Specification【311】
- Raft:作者维护的算法与论文入口【491】
- etcd v3.5:revision、条件事务与租约【487】
- Martin Kleppmann:How to do distributed locking(2016)【468】(引用进程暂停、租约与 fencing token 的分析,不将其 Redis 版本结论推广到当前产品)
- AutoGen: Enabling Next-Gen LLM Applications via Multi-Agent Conversation【492】
- CAMEL: Communicative Agents for Mind Exploration of Large Language Model Society【493】
资料核对:2026-09-15。Anthropic 与 Cognition 的对照限于文中所述的 2025 年系统和模型;未复现其内部评测。A2A 按 v1.0.1 发布标签核对,不以文档页顶部残留的 Latest Released Version 1.0.0 文案替代版本依据。
- MemGPT: Towards LLMs as Operating Systems【470】
- Anthropic: Effective context engineering for AI agents【307】
- Chroma Research: Context Rot【353】
- LangChain: Context Engineering for Agents【444】
- Anthropic Prompt Caching【494】
- OpenAI Prompt Caching【80】
- OpenAI Compaction【495】
- LangGraph Memory【496】
- LoCoMo 官方发布说明快照 9228632【478】(ACL 2024 发布集;固定版本的
data/locomo10.zip内含十份按对话划分的 JSON 文件) - LongMemEval 官方说明快照 9e0b455【476】(区分原始版与 2025 年 9 月清洗版)
- LongMemEval-V2 官方说明快照 2cc8c54【479】
资料核对:2026-09-15。OpenAI 缓存与 Compaction 引用的是 Responses API 滚动文档,不承诺跨模型或跨版本相同的价格、阈值与历史传递规则;本次未实测服务端接口。Anthropic 缓存条目保留为补充阅读,未据此新增具体参数结论。
- Chain-of-Thought Prompting Elicits Reasoning in Large Language Models【104】
- Tree of Thoughts: Deliberate Problem Solving with Large Language Models【112】
- Graph of Thoughts: Solving Elaborate Problems with Large Language Models【457】
- Plan-and-Solve Prompting【460】
- LLMCompiler: An LLM Compiler for Parallel Function Calling【454】
- Anthropic: Building Effective Agents【275】
- LLMs Can't Plan, But Can Help Planning in LLM-Modulo Frameworks【497】
- Do As I Can, Not As I Say: Grounding Language in Robotic Affordances【498】
- OR-Tools: CP-SAT Solver【499】
- DeepSeek-R1【301】
- Self-Refine: Iterative Refinement with Self-Feedback【459】
- Reflexion: Language Agents with Verbal Reinforcement Learning(v4)【500】
- Language Agent Tree Search Unifies Reasoning, Acting, and Planning(v3)【501】
- Improving Factuality and Reasoning in Language Models through Multiagent Debate【502】
- Anthropic: Building Effective Agents【275】
- Large Language Models Cannot Self-Correct Reasoning Yet【503】
- Training Language Models to Self-Correct via Reinforcement Learning(SCoRe,v1)【504】
框架行为按 2026-09-15 可访问的官方文档核对;实际部署仍需锁定 SDK 版本。A2A v1.0.1 Release【309】发布于 2026-05-28,但该标签中的规范页提示仍写 v1.0.0;本章按发布标签而非页面的 latest 提示确定规范版本。
- LangGraph Graph API【506】
- LangGraph:并行状态更新错误【507】
- LangGraph Persistence【483】
- OpenAI Agents SDK【508】
- OpenAI Swarm:迁移至 Agents SDK 的官方说明【509】
- OpenAI Agents SDK: Handoffs【510】
- A2A v1.0.1 Protocol Specification【311】
- Amazon SQS:至少一次投递【511】
- etcd v3.6:API 一致性与租约保证【512】
- etcd v3.6:Lock 与事务保护【513】
- AWS:Transactional Outbox【486】
- Raft:作者维护的算法与论文入口【491】
- Anthropic: Building Effective Agents【275】
- SWE-bench: Can Language Models Resolve Real-World GitHub Issues?【154】
- OpenAI: Why SWE-bench Verified no longer measures frontier coding capabilities【155】
- SWE-Lancer: Can Frontier LLMs Earn $1 Million from Real-World Freelance Software Engineering?【516】
- Terminal-Bench:官方任务与版本入口【517】
- GAIA: a benchmark for General AI Assistants【518】
- tau-bench: A Benchmark for Tool-Agent-User Interaction in Real-World Domains【162】
- tau^2-Bench: Evaluating Conversational Agents in a Dual-Control Environment【519】
- OSWorld: Benchmarking Multimodal Agents for Open-Ended Tasks in Real Computer Environments【218】
- WebArena: A Realistic Web Environment for Building Autonomous Agents【219】
- BrowseComp: A Simple Yet Challenging Benchmark for Browsing Agents【520】
- AgentBench: Evaluating LLMs as Agents【521】
- MLE-bench: Evaluating Machine Learning Agents on Machine Learning Engineering【522】
- Humanity's Last Exam【165】
- AgentDojo: A Dynamic Environment to Evaluate Prompt Injection Attacks and Defenses for LLM Agents【523】
- OpenTelemetry: Generative AI Semantic Conventions【524】
- OpenTelemetry: GenAI 约定状态说明(Development,固定提交 0c87594)【525】
- Anthropic: Building Effective Agents【275】
- Anthropic: Demystifying evals for AI agents【526】
- SWE-bench: Evaluation harness【527】
- OpenAI: BrowseComp reference implementation【528】
- Anthropic: How we built our multi-agent research system【488】
第十五章:Agent 安全与 Prompt Injection
- Simon Willison: The lethal trifecta for AI agents【530】
- Simon Willison: The Dual LLM pattern for building AI assistants that can resist prompt injection【531】
- Design Patterns for Securing LLM Agents against Prompt Injections(v1)【532】
- Defeating Prompt Injections by Design(CaMeL,v2)【533】
- Not what you've signed up for: Compromising Real-World LLM-Integrated Applications with Indirect Prompt Injection【418】
- AgentDojo: A Dynamic Environment to Evaluate Prompt Injection Attacks and Defenses for LLM Agents【523】
- The Task Shield: Enforcing Task Alignment to Defend Against Indirect Prompt Injection in LLM Agents【534】
- System-Level Defense against Indirect Prompt Injection Attacks: An Information Flow Control Perspective【535】
- Bypassing LLM Guardrails: An Empirical Analysis of Evasion Attacks against Prompt Injection and Jailbreak Detection Systems(v3)【536】
- OWASP Top 10 for LLM Applications【341】
- Docker Engine:Linux 容器的 seccomp 配置与边界【537】
- Anthropic: Equipping agents for the real world with Agent Skills【303】
- MCP 2026-07-28: Security Best Practices【343】
- Anthropic: Building Effective Agents【275】
- SWE-agent: Agent-Computer Interfaces Enable Automated Software Engineering【538】
- METR: Measuring AI Ability to Complete Long Software Tasks【539】
- Simon Willison: Designing agentic loops【540】
- Claude Agent SDK: Overview【541】
- GitHub Docs: Configure the development environment for Copilot cloud agent【542】
- LangGraph: Persistence【483】
- Microsoft Agent Framework Overview【442】
- Claude Agent SDK: How the agent loop works【545】
- OpenAI Agents SDK: Running agents【546】
- Anthropic: Building Effective Agents【275】
- LangGraph: Subgraphs【547】
- Simon Willison: Designing agentic loops【540】
第十八章:Context Engineering 与上下文装配
- Anthropic: Effective context engineering for AI agents【307】
- Model Context Protocol: Tools【285】
- Claude Agent SDK: Modifying system prompts【548】
- OpenAI: Prompt caching【80】:前缀匹配、模型差异与缓存断点,查阅于 2026-09-15。
- Anthropic Prompt Caching【494】:保留原技术来源;本轮访问跳转至区域不可用页面,未据此确认当前参数。
- LangChain: Context Engineering for Agents【444】
- Model Context Protocol: Tools【285】
- Model Context Protocol: Versioning【276】:2026-07-28 的 Current 状态与修订规则,查阅于 2026-09-15。
- OpenAI Agents SDK: Guardrails【549】
- Anthropic: Code execution with MCP【446】
- Cloudflare: Code Mode — the better way to use MCP【447】
- RAG-MCP: Mitigating Prompt Bloat in LLM Tool Selection via Retrieval-Augmented Generation【448】
- Claude Agent SDK: Configure permissions【550】
- gVisor 文档【551】
- GitHub Docs: Configure the development environment for Copilot cloud agent【542】
- GitHub Docs: Customizing or disabling the firewall【552】
- Simon Willison: Designing agentic loops【540】
- Simon Willison: The lethal trifecta for AI agents【530】
SDK 权限顺序与 GitHub 环境、防火墙范围按 2026-09-15 的官方文档核对;anthropic/requiresUserInteraction 的 v2.1.199 前提保留。未在本轮运行 SDK 权限实验或配置云端环境。
第二十一章:Checkpoint、持久化、重试、超时、幂等与恢复
- LangGraph: Persistence【483】
- LangGraph: Interrupts【553】:恢复时重新进入节点,节点内中断之前的代码会再次执行。
- LangGraph: Fault tolerance【554】
- Temporal: Retry Policies【555】
- Stripe: Idempotent requests【556】
- LangGraph 第十章:LangGraph 的核心优势
第二十二章:Human-in-the-loop、审批与可中断执行
- Model Context Protocol: Tools【285】
- Simon Willison: Designing agentic loops【540】
- Claude Agent SDK: Configure permissions【550】
- LangGraph: Human-in-the-loop【553】
- AWS Prescriptive Guidance: Transactional outbox pattern【486】:状态写入与通知投递的双写问题,以及重复消息的幂等处理。
- LangGraph 第十章:LangGraph 的核心优势
第二十三章:Tracing、评测、成本控制与 Coding Agent Harness 案例
- OpenTelemetry: Generative AI Semantic Conventions【524】
- OpenTelemetry: Traces【557】:Span、Span event、上下文传播与 Span links。
- Claude Agent SDK: How the agent loop works【545】
- OpenAI Agents SDK: Running agents【546】
- OpenAI Agents SDK: Guardrails【549】
- OpenAI Codex repository【558】
- GitHub Docs: Configure the development environment for Copilot cloud agent【542】
- Simon Willison: Designing agentic loops【540】
- Anthropic: How we built our multi-agent research system【488】
GenAI 语义约定固定在提交 0c87594975195608dc91b3f702e250a7b240c151,查阅于 2026-09-15;产品接口以本章所引官方文档为边界,不据此推断未公开的内部实现。
第二十四章:Coding Agent 的代码搜索、编辑与验证
- 李博杰(Bojie Li),《深入理解 AI Agent:设计原理与工程实践》第五章相关段落【559】:用于搜索类别、编辑格式与即时反馈的讨论。固定提交
985a49d35b9f50937f1f757cf25867672991ded7,查阅于 2026-09-14。 - 同提交
edit_tool.py【560】:用于匹配与写后检查的讨论,尤其是先写文件、后检查且不自动回滚的执行顺序。 - Language Server Protocol 3.17【561】:定义、引用、调用层级与位置编码机制。查阅于 2026-09-14。
- Python
ast.parse文档【562】:解析 AST 与完整编译检查的边界。查阅于 2026-09-14。
- 李博杰,
ai-agent-book第七章:失败归因、精确复制排查与轨迹前缀回归【563】。 - 李博杰,第八章:多轮信用分配、奖励与在轨蒸馏【564】,从问题案例到后训练【565】。
- 李博杰,配套实验:过早结束的 DPO 修复 README【566】,重点参照数据、评估指标口径与可信根说明。
资料查阅于 2026-09-14,固定提交为 985a49d35b9f50937f1f757cf25867672991ded7。DPO 结果仅转述 README,未独立复现训练;其中候选比较与自由生成的差异不能外推为总体任务完成率提升。RLVP 等方法线索不代表本章完成了相应训练实验。
- LangChain 官方文档【567】
- LangGraph 官方文档【568】
- LlamaIndex 官方文档【569】
- OpenAI Agents SDK【508】
- CrewAI 官方文档【570】
- AutoGen 仓库【443】
- Anthropic: Building effective agents【275】
- LangChain 官方文档【567】
- RunnableSequence:LCEL 组合、批处理与流式语义【571】
- Runnable API【572】
- langchain-core Runnables API 参考【573】
- LangChain v1 迁移指南【574】
- LangGraph 官方文档【568】
- LangChain 官方文档【567】
- LangChain: Agents 概念文档【575】
- LangChain: Messages 概念文档【576】
- LangChain: Tools 概念文档【577】
- LangChain: Middleware 概念文档【578】
- LangChain v1 迁移指南【574】
- LangGraph 官方文档【568】
- LangGraph Checkpointers:super-step 与 pending writes【485】
第四章:用 LangChain 构建生产级 Agent 的七步
- LangChain: Agents 概念文档【575】
- LangChain: Tools 概念文档【577】
- LangChain: Structured Output【579】
- LangChain: Middleware【578】
- LangChain: Short-term Memory【438】
- LangChain: Long-term Memory【580】
- LangChain: Streaming【581】
- LangGraph 持久化文档【483】
- LangChain Human-in-the-loop:审批与恢复【582】
- LangGraph Graph API:recursion limit【583】
- LangChain: Tools 概念文档【577】
- LangChain: Agents 概念文档【575】
- LangChain: Middleware【578】
- langchain-core Tools API 参考【584】
- Pydantic 官方文档【585】
- LangChain: Short-term Memory【438】
- LangChain: Long-term Memory【580】
- LangGraph 持久化文档【483】
- LangGraph Store 文档【586】
- LangChain: Middleware【578】
- LangChain v1 迁移指南【574】
第七章:LangChain 与 LlamaIndex 的分工
- LangChain 官方文档【567】
- LangChain: Agents 概念文档【575】
- LangChain: Retrieval 概念文档【587】
- LangGraph 官方文档【568】
- LlamaIndex 官方文档【569】
- LlamaIndex: Building an Agent【588】
- LlamaIndex: Workflows【589】
- LangChain4j 官方文档【590】
- LangChain4j GitHub 仓库【591】
- LangChain4j: AI Services 教程【592】
- LangChain4j: Tools 教程【593】
- LangChain4j: Chat Memory 教程【594】
- LangChain4j: RAG 教程【595】
- LangChain4j: Guardrails 与执行顺序【596】
- LangChain4j: AI Service Observability【597】
- Quarkus LangChain4j【598】
- Spring AI 官方文档【599】
第九章:LangChain 与 LangGraph 的层次关系
- LangChain 官方文档【567】
- LangChain: Agents 概念文档【575】
- LangChain: Middleware【578】
- LangChain: Streaming【581】
- LangGraph 官方文档【568】
- LangGraph: Graph API【543】
- LangGraph 持久化文档【483】
- LangGraph: Human-in-the-loop【553】
- LangSmith 官方文档【600】
- LangGraph Python 包依赖声明【601】
- LangGraph 并行状态更新错误【507】
- LangGraph 官方文档【568】
- LangGraph: Graph API【543】
- LangGraph: Functional API【544】
- LangGraph 持久化文档【483】
- LangGraph: Human-in-the-loop【553】
- LangGraph: Time Travel【602】
- LangGraph: Subgraphs【547】
- LangGraph: Fault tolerance【554】
- LangChain: Event streaming【603】
- LangChain: Agents 概念文档【575】
- LangGraph Checkpointers:检查点与恢复语义【485】
- LangGraph 并行状态更新错误【507】
- LangChain v1 迁移指南【574】
- LangChain 官方文档【567】
- LangChain v1 发布说明【604】
- LangChain v0.3 官方发布说明(Pydantic 2 迁移)【605】
- LangChain 官方博客【606】
- LangGraph 官方文档【568】
- Pydantic 迁移指南【607】
- LangChain Structured output:能力与最低版本【579】
- LangGraph Fault tolerance【554】
- LangGraph Graph API:graph migrations【608】
- LangChain Event streaming【603】
- LangChain 官方博客:Open Deep Research【609】
- open_deep_research 官方仓库【610】
- Deep Agents 概览【611】
- Deep Agents Backends【612】
- Deep Agents Sandboxes【613】
- Deep Agents 同步子 Agent【614】
- Deep Agents 异步子 Agent【615】
- deepagents 官方仓库【616】
- LangGraph 官方文档【568】
- LangSmith Evaluation 文档【617】
- Anthropic: Building Effective Agents【275】
- LangSmith Observability【600】
- LangSmith Evaluation【617】
- LangSmith 管理 Dataset【618】
- LangSmith Online evaluation【619】
- LangSmith 用户反馈【620】
- LangSmith 发送前隐藏与转换敏感数据【621】
- LangSmith 实验重复次数、并发与缓存【622】
- LlamaIndex 官方文档【623】
- LlamaIndex: Loading Data (Ingestion Pipeline)【624】
- LlamaIndex: Indexing 概念【625】
- LlamaIndex: 各索引的默认与可选检索方式【626】
- LlamaIndex: Property Graph Index【627】
- LlamaIndex: Storage 概念【628】
第十五章:LlamaIndex 的查询引擎与 Workflows 编排
- LlamaIndex: Query Engine 概念【630】
- LlamaIndex: Routers 与 selector【631】
- LlamaIndex: Workflows【632】
- LlamaIndex: Workflows 共享状态【633】
- LlamaIndex: Durable Workflows【634】
- LlamaIndex: WorkflowServer 部署【635】
- LlamaIndex: BaseSynthesizer 的 query / nodes 接口【636】
- LangGraph 官方文档【568】
第十六章:DSPy 的声明式编程模型:Signature、Module 与 Program
- DSPy 官方文档【637】
- DSPy: Class-based signatures【638】
- DSPy: Changing modules【639】
- DSPy 论文:Khattab et al., "DSPy: Compiling Declarative Language Model Calls into Self-Improving Pipelines"【640】
- DSPy: 选择优化器【641】
- DSPy: MIPROv2 API 与三阶段机制【642】
- DSPy: GEPA API 与反馈契约【643】
- DSPy: GEPA 优化教程【644】
- DSPy 论文:Khattab et al., "DSPy: Compiling Declarative Language Model Calls into Self-Improving Pipelines"【640】
- GEPA 论文:Agrawal et al., "GEPA: Reflective Prompt Evolution Can Outperform Reinforcement Learning"【645】
- LangSmith 官方文档【646】
第十八章:Semantic Kernel 的核心抽象:Kernel、Plugin 与 Planner
- Semantic Kernel 官方文档:Introduction【647】
- Semantic Kernel: Kernel 概念【648】
- Semantic Kernel: Plugins 概念【649】
- Semantic Kernel: Planning 概念【650】
- Semantic Kernel: Filters 概念【651】
- Semantic Kernel 官方仓库与后继框架说明(固定提交)【652】
版本说明:MAF 后继关系与 1.0 发布声明于 2026-09-15 复核;该声明不覆盖全部语言和实验性扩展,具体边界见第十九章。
第十九章:Semantic Kernel 的 Process Framework 与 Agent Framework
- Semantic Kernel: Process Framework【653】
- Semantic Kernel: Agent Framework 概述【654】
- Semantic Kernel: Agent Orchestration【655】
- Semantic Kernel: Group Chat 完整运行时示例【656】
- Semantic Kernel 官方仓库的 MAF 1.0 说明(固定提交)【652】
- Microsoft Agent Framework 概览【442】
- SK → MAF 迁移指南【657】
- 微软:Semantic Kernel 与 MAF 支持过渡公告【658】
- LangGraph 官方文档【568】
版本说明:MAF 1.0、Go public preview、SK Process/Orchestration 实验性标记和过渡公告于 2026-09-15 复核。过渡公告保留了发布当时「MAF 仍在 Preview」的描述,不能用它覆盖后续 1.0 发布声明,也不能据此推算 SK 的精确 EOL。
- AutoGen 官方文档【659】
- AutoGen: Core 用户指南【660】
- AutoGen: AgentChat 用户指南【661】
- AutoGen 官方仓库:Maintenance Mode(固定提交)【662】
- AutoGen → MAF 迁移指南【663】
- AutoGen: 保存与加载 Agent/Team 状态【664】
- CrewAI 官方文档【570】
- CrewAI: Flows 概念【665】
- CrewAI: Crews 概念【666】
- CrewAI: Processes 的顺序与层级执行【667】
版本说明:AutoGen 维护模式及后继建议于 2026-09-15 对照上述固定提交复核;本章代码保留 Core/AgentChat 代际,不改写成 MAF API。
第二十一章:PydanticAI 的类型安全范式与三者适用边界
- PydanticAI 官方文档【668】
- PydanticAI: Agents 核心概念【669】
- PydanticAI: Function Tools【670】
- PydanticAI: Dependencies 依赖注入【671】
- AutoGen 官方文档【659】
- CrewAI 官方文档【570】
- PydanticAI: 输出模式与校验【672】
- PydanticAI: Durable Execution【673】
- AutoGen: State【664】
第二十二章:跨框架技术解构:状态、持久化、工具契约与可观测性
- LangGraph: Persistence 概念【483】
- LangGraph: Checkpointers 与 super-step【485】
- LlamaIndex: Workflows【632】
- LlamaIndex: Durable Workflows【634】
- AutoGen: State【664】
- CrewAI: Flows【665】
- PydanticAI: Durable Execution【673】
- Microsoft Agent Framework 概览【442】
- Semantic Kernel: Process Framework【653】
- OpenTelemetry Generative AI 语义约定及状态【674】
- LangSmith 官方文档【646】
版本说明:微软框架的发布与维护状态见第十九、二十章的固定来源;OpenTelemetry GenAI 的 Development 标记于 2026-09-15 复核。不同导出器仍需锁定并验证各自采用的语义约定版本。
- LangGraph: Persistence 概念【483】
- Semantic Kernel: Process Framework【653】
- Microsoft Agent Framework 概览与后继关系【442】
- SK → MAF 迁移指南【657】
- AutoGen 官方维护模式说明【443】
- PydanticAI: Durable Execution【673】
- OpenTelemetry Generative AI 语义约定仓库【524】
- Martin Fowler: StranglerFigApplication【675】
- Martin Fowler: CanaryRelease【676】
- Alistair Cockburn: Hexagonal Architecture【677】
第一章:LLMOps 是什么:与 MLOps、DevOps 的边界
- Google Cloud: MLOps: Continuous delivery and automation pipelines in machine learning【678】
- a16z: What Is LLMOps?【679】
- Chip Huyen: Building LLM applications for production【680】
- OpenAI: Best practices for production deployments【681】
- Anthropic: Building effective agents【275】
- OpenAI: Production best practices【681】
- Anthropic: Building effective agents【275】
- Google SRE Book: Chapter 1 - Introduction【682】
- Uber Engineering: Michelangelo Machine Learning Platform【683】
- Martin Fowler: Continuous Delivery for Machine Learning【684】
- LiteLLM: Routing【685】
- OpenAI: Reasoning models【117】
- Amazon Bedrock: Model routing (intelligent prompt routing)【686】
- Martin Fowler: CanaryRelease【676】
- Netflix Tech Blog: Fault Tolerance in a High Volume, Distributed System【687】
- Google Cloud: Implementing exponential backoff【688】
- Stripe API: Idempotent requests【556】
- Martin Fowler: CircuitBreaker【689】
- Netflix Tech Blog: Fault Tolerance in a High Volume, Distributed System【687】
- AWS Well-Architected Framework: REL05-BP04 Bulkhead architecture【690】
- OpenAI: Structured Outputs【691】
- OpenAI: Reasoning models【117】
- OpenAI: Function calling【294】
- Anthropic: Tool use with Claude【692】
- JSON Schema Specification【693】
- Pydantic: Validators【694】
- OpenAI: Moderation API【695】
- OWASP Top 10 for LLM Applications【341】
- Anthropic: Guardrails against misuse【696】
- NIST AI Risk Management Framework【176】
- Google Cloud: Responsible AI practices【697】
第七章:离线评测与 Eval-Driven Development
工具生命周期不等于评测方法生命周期:OpenAI 的 2026-06-03 公告写明,其托管 Evals 平台将于 2026-10-31 转为只读,Evals dashboard 和 API 计划于 2026-11-30 关闭。采用该平台时需核对迁移计划;不能据此声称开源 openai/evals 或自建评测方法一并失效。
- OpenAI Evals【698】
- OpenAI: Evaluation best practices【699】
- OpenAI: 2026-06-03 Evals platform deprecation【700】
- Anthropic: Demystifying evals for AI agents【526】
- SciPy: Binomial proportion confidence intervals【701】
- Google: Rules of Machine Learning - Rule #4: Keep the first model simple and get the infrastructure right【702】
- Braintrust: What is an eval?【703】
- LangSmith: Evaluation concepts【704】
原 GenAI 文档入口已迁移至独立仓库,旧入口不再维护;本次于 2026-09-15 核对迁移说明。
- OpenTelemetry: Semantic conventions for generative AI systems【705】
- OpenTelemetry: GenAI semantic conventions repository【524】
- Google SRE Book: Monitoring Distributed Systems【706】
- LangSmith Observability【600】
- Arize Phoenix: Tracing【707】
- Honeycomb: Observability for LLMs【708】
- OpenAI: GPT-4o snapshots【709】
- OpenAI: Deprecations【710】
- DVC: Data Version Control【711】
- MLflow: Model Registry【712】
- Google Cloud: MLOps continuous delivery and automation pipelines【678】
第十章:LLM CI/CD 与灰度、Canary、A/B 发布
- Martin Fowler: CanaryRelease【676】
- Google SRE Workbook: Canarying Releases【713】
- SciPy: ttest_ind,独立样本与 Welch 检验前提【714】
- Martin Fowler: Continuous Delivery for Machine Learning【684】
- Spinnaker: Canary Analysis【715】
- Optimizely: Statistical significance in A/B testing【716】
- Anthropic: Prompt caching【494】
- OpenAI: Prompt caching【717】
- OpenAI: Batch API【718】
- Anthropic: Message Batches API【719】
- Google Cloud: Cost optimization for AI and ML workloads【720】
- Google SRE Book: Service Level Objectives【721】
- Google SRE Workbook: Implementing SLOs【722】
- OpenAI: Rate limits【723】
- Anthropic: Rate limits【724】
- PagerDuty: Incident Response Documentation【725】
- OpenAI: Fine-tuning【726】
- Anthropic: Constitutional AI and RLHF【727】
- LangSmith: Attach user feedback【620】
- Netflix Tech Blog: Recommendation systems and the data flywheel【728】
- Google: People + AI Guidebook - Feedback + Control【729】
- MITRE ATLAS【730】
- NIST AI Risk Management Framework (AI RMF 1.0)【176】
- NIST Generative AI Profile (NIST AI 600-1)【731】
- OWASP Top 10 for Large Language Model Applications【341】
- OWASP Agentic AI Threats and Mitigations【732】
- OWASP Top 10 for Agentic Applications 2026【733】
- NIST AI 100-2 E2025: Adversarial Machine Learning Taxonomy【734】
第二章:Prompt Injection、Jailbreak 与系统提示泄漏
- OWASP LLM01:2025 Prompt Injection【735】
- OWASP LLM07:2025 System Prompt Leakage【736】
- Many-shot Jailbreaking (Anthropic)【737】
- Universal and Transferable Adversarial Attacks on Aligned Language Models【738】
- Ignore This Title and HackAPrompt: Exposing Systemic Vulnerabilities of LLMs【739】
- MITRE ATLAS: Prompt Injection【740】
- OWASP LLM05:2025 Improper Output Handling【741】
- OWASP LLM02:2025 Sensitive Information Disclosure【742】
- Imprompter: Tricking LLM Agents into Improper Tool Use【743】
- Not what you've signed up for: Compromising Real-World LLM-Integrated Applications with Indirect Prompt Injection【418】
- OWASP: CSV Injection【744】
- Poisoning Web-Scale Training Datasets is Practical【745】
- Anthropic / UK AISI / Alan Turing Institute: Small samples can poison language models【746】
- BadNets: Identifying Vulnerabilities in the Machine Learning Model Supply Chain【747】
- A Backdoor Attack Against LSTM-based Text Classification Systems【748】
- On the Exploitability of Instruction Tuning【749】
- OWASP LLM04:2025 Data and Model Poisoning【750】
- NIST AI 100-2 E2025: Adversarial Machine Learning Taxonomy【734】
- OWASP LLM03:2025 Supply Chain【751】
- Hugging Face: Pickle Scanning and Safetensors【752】
- PyTorch 2.6: Serialization semantics and weights_only【753】
- Sleepy Pickle: Exploiting Machine Learning Pickle Files【754】
- MITRE ATLAS: ML Supply Chain Compromise【755】
- CycloneDX: Machine Learning Bill of Materials (ML-BOM)【756】
- Sigstore: Software Signing for Everyone【757】
- Extracting Training Data from Large Language Models【758】
- Quantifying Memorization Across Neural Language Models【759】
- Membership Inference Attacks against Machine Learning Models【760】
- Deep Learning with Differential Privacy (DP-SGD)【761】
- OWASP LLM02:2025 Sensitive Information Disclosure【742】
- NIST AI 600-1: Generative AI Profile — Privacy risks【731】
- OpenAI: Data controls in the API platform【170】
- GDPR 原文:第 5、6、17 条及第五章【762】
第七章:Agent、Tool、MCP、A2A 最小权限与身份治理
- Confused Deputy Problem (Norm Hardy, 1988)【763】
- MCP 2026-07-28 Authorization: Confused Deputy Considerations【342】
- RFC 8693: OAuth 2.0 Token Exchange,尤其 1.1、4.1 节【764】
- RFC 7662: OAuth 2.0 Token Introspection【765】
- OWASP Agentic AI Threats and Mitigations: Identity and Authorization【732】
- NIST SP 800-207: Zero Trust Architecture【766】
- SPIFFE/SPIRE: Workload Identity Framework【767】
第八章:代码执行、浏览器与 Computer Use 沙箱及网络隔离
- OWASP LLM06:2025 Excessive Agency【768】
- gVisor: Application Kernel for Containers【769】
- Firecracker: Secure and Fast microVMs【770】
- MDN: Same-origin policy【771】
- Anthropic: Computer Use Demo — security precautions and isolation limitations【772】
- MITRE ATLAS: Evade ML Model / LLM Prompt Injection【740】
- NIST AI RMF: Measure Function【176】
- garak: LLM Vulnerability Scanner【773】
- PyRIT: Python Risk Identification Tool for generative AI【774】
- HarmBench: A Standardized Evaluation Framework for Automated Red Teaming【775】
- Red Teaming Language Models with Language Models【776】
- OWASP LLM Applications Cybersecurity and Governance Checklist【777】
法规核对日期:2026-09-15。2026/1744 于 2026-07-24 刊登《欧盟官方公报》,依第 4 条在公布后第三日(2026-07-27)生效;第 1 条 (40) 项修改 AI Act 第 113 条,第 (39) 项涉及既有系统过渡安排。正文引用的是已生效修订,不是提案或政治协议。C2PA 的能力说明采用下列 2.2 版,不声称它是最新版本。
- NIST AI RMF: Govern Function【176】
- EU AI Act:Regulation (EU) 2024/1689 原文【778】
- Regulation (EU) 2026/1744:第 1 条 (39)、(40) 项与第 4 条【779】
- GDPR:第 33、34 条,数据事件通知的条件与时限【762】
- European Commission: AI Act policy overview【780】
- C2PA 2.2: Explainer,验证能力与非目标【781】
- Model Cards for Model Reporting【782】
- System Cards: A New Resource for Understanding How AI Systems Work【783】
- OWASP LLM Applications Cybersecurity and Governance Checklist【777】
第一章:Forward Deployed Engineering:从业务问题到可复用生产系统
原资料整理日期:2026-09-08。当时 Palantir 的三篇 Medium / 工程博客链接返回 403,保留作延伸阅读,正文不依赖其中的项目细节;OpenAI Gov 招聘链接仅作为岗位入口。
2026-09-15 复核了正文涉及的 Evals 退役、API 数据控制,以及 Microsoft、Baseten、AWS/INRIX 的具体案例表述。OpenAI 的公告仍列明:Evals 平台将于 2026-10-31 转为只读,并计划于 2026-11-30 关闭仪表盘和 API。旧指南中的评测方法与托管平台操作需分开使用;这不代表开源评测方法失效。
- Palantir:Dev versus Delta——工程角色的区别【784】
- Palantir:A Day in the Life of a Forward Deployed Software Engineer【785】
- Palantir:AIP Chatbot Studio 概览【786】
- Palantir:Security and governance【787】
- OpenAI Deployment Company:Build, Prove, Generalize【788】
- OpenAI:Forward Deployed Engineer, Gov【789】
- OpenAI:Evaluation best practices(方法与托管平台需区分)【699】
- OpenAI:Deprecations(含 Evals 平台时间表)【710】
- OpenAI:Production best practices【790】
- OpenAI:Data controls【170】
- Anthropic:Building Effective AI Agents【275】
- Anthropic:How we built Claude Managed Agents【791】
- Palantir:Securing Software at the Speed of AI(官方工程案例,2026)【792】
- Anthropic:Demystifying evals for AI agents(官方工程文章)【526】
- Microsoft:Only Believe What You Can Validate(客户现场工程分享,2026)【793】
- Baseten:Forward Deployed Engineering on the Frontier of AI(官方团队实践,2025)【794】
- AWS 与 INRIX:交通规划 PoC 实践(客户与厂商共同撰写,2025)【795】
- @vasuman:Forward Deployed Engineering 101(X 一线从业者长文)【796】
- Hamel Husain:A Field Guide to Rapidly Improving AI Products【797】
- Varick Agents:Careers【798】
- run_maotui:产品工作中的 AI 协作分享【799】(1.2.1 节的参考:调研核实、需求取舍、PRD 交接与项目决策维护;查阅于 2026-09-17)
资料整理日期:2026-09-10;2026-09-15 另按所引提交复核了 OpenFDE 的评测记录、任务接受条件与 Claude 抽取数据流。本章借鉴工作方法并用订单场景重新组织,不把原项目的全部流程当作通用标准。链接固定到阅读时的提交,方便对照。
| 项目 | 建议先看哪里 | 引用版本 |
|---|---|---|
| Applied AI Field Guide【800】 | 五分钟导读【801】、发票案例中的范围调整和接手演练 | 6b557eb |
| FDEstack【802】 | 八个 Skills 的总览【803】,尤其是待确认问题、PoC 结论和生产实现之间的衔接 | 5524460 |
| OpenFDE【804】 | 架构说明【805】,看来源、事实、任务和上下文怎样连接 | e2dec16 |
| FDEOps【806】 | 项目总览【807】、需求变更和交接技能 | cc96340 |